Error -9997 when trying to overdub

I have Audacity 2.3.3 installed on two desktop computers. On one I can overdub just fine. But on the other, no matter what I do, I get Error code: -9997 as soon as I shift-click the record button with another track displayed. Here is the error dialog box:
I have checked the settings on the two computers. They are identical. I have uninstalled Audacity, deleted the C:\Program Files (x86)\Audacity\ directory, and done a clean install. No luck. Same problem. I can’t imagine what’s wrong. I would appreciate any help that anyone can provide. Thank you.

Jesse Heines

I have updated the subject of the thread to match your description of the problem.
I also removed your email address as this is a public forum (spam bots regularly trawl public forums looking for new victims).
As you are on Windows, I have moved the topic to the Windows forum.

Check in the Windows Sound setting, and ensure that the sound card that you are using is set to a sample rate of 44100 in both the Recording tab and the Playback tab. Then open Audacity and check that the “Project Rate” (lower left corner) is also set to 44100.

Thank you very much, Steve. I really appreciate your help. You were 100% correct. The mic’s advance properties revealed that it was set to 44000 Hz rather than 41000. Once again, thank you.

I tried doing that but for some reason when I try to apply it, it says that “Format not supported by the device” in both my usb mic and my default mic.

What problem are you trying to solve?
What is the default format?

(The best way to include images in a post is to add them to the post as “Attachments” and then “Place inline”. See:

So if 44100 is not supported by your device, try something that is, perhaps 48000?

Then, set Audacity’s project rate (lower left-hand corner) to that rate. Be sure that both recording and playback devices are set to the same rate.