Error - 9997: Invalid Sample Rate on a MacBook Pro and using Audacity

I just purchased a ZealSound K66 USB mic. I am using it with a MacBook Pro (Ventura 13.6.6) and Audacity (3.4.2) software.

I don’t appear to be able to record on Audacity and I keep getting an error message -

Error -9997: Invalid Sample Rate

I’ve tried to change the sample rate and from mono to stereo recording, all to no avail.

Can anyone suggest any way to address the issue? I know there have been several discussions on this topic but nothing I’ve seen and tried resolves the issue.

Many thanks

Hamer

EDIT - UPDATE

I now am able to record. However, I’m having a different but related problem, I think. I created an aggregate Mic from the K66 USB and an SM58 USB. Both mics record independently but either the SM58 or the K66 will not record when part of the aggregate (I am picking the aggregate as the Input choice). I had previously aggregated the SM58 with the MacPro internal mic and separately the K66 with the MacPro internal mic and tested their respective aggregates; they both worked fine! Could the K66 be causing some functional issues? Are the K66 and SM58 USB mics together taking up too much space and so only one at a time can function when aggregated?
Any ideas? However, note, the K66 and SM58 aggregate operates fine with VoiceMemo on the Mac, they both record fine. It appears Audacity has an issue only.

EDIT - RESOLUTION

  1. Aggregate your mics
  2. Audacity Tracks → set up 2 separate MONO tracks
  3. Audacity Set Up - ‘Recording Channels’ - ensure you pick ‘STEREO’ option. This is essential to get the two mics working and not just one.
  4. Your two mics should now record separately on either of the mono tracks.

https://www.youtube.com/watch?app=desktop&v=zZrkvPKllY8&t=0 - this video explains the STEREO choice I missed but note he has previously aggregated his two mics into one choice.