Error 9997 at start up [SOLVED]

I have a clean install of Audacity on a windows 10 computer. When I try to record I am getting error 9997 There is no external mic or other devices. I am simply recording from sound playing on the computer only. Any thoughts? I have attached a screen capture of the setup. I have tried every project rate and every other option below the record button. nothing records and what should work is giving me an error.

In the Windows Sound Control Panel, set the “sample rate”, for Playback AND Recording, of the “High Definition Audio” device, to 44100.

If you can’t change the sample rate to 44100, it may be due to a recent Windows update that has partially broken the Windows sound settings, so see here in the Audacity “alpha” manual (the manual for the next version of Audacity) for how to proceed:

I am running windows 10 and Audacity 2.3.0

So I made sure recording and playback were set to 44100. I turned off the transport options. The software is also set at the bottom to 44100. Still get the error. Any other suggestions.

What are you trying to record?

To help us troubleshoot the issue, save the “Audio Device Info” ( and attach the saved text file to your reply.

OK, here are the debug files. (61.9 KB)

Here is the file.
deviceinfo.txt (5.82 KB)

Is this a laptop computer?

What are you trying to record?
Are there any other audio applications (such as Skype) running at the same time? (including anything running in the background).

I was going to suggest that you try recording from your microphone, but there is no microphone showing up in Device Info. In fact there are no analog inputs at all :open_mouth: Is there an obvious reason for that?

This problem has been driving me nuts all day today. But, finally, I found an answer to my problem.
Like RDavidson, I’m on a Win 10 desktop, and tried to record using Audacity 2.0.3. Couldn’t get it to record from my Line In. I updated to Audacity 2.3.0, and the problem continued. I “updated” my Realtek driver from Lenovo’s website. Not a fix. I tried all combos of the settings in the devices toolbar, and on Windows’ Sound settings. I looked at the Privacy permissions, and did not find Audacity listed among the permitted apps.

Finally, I discovered that there are 2 permissions that must be set correctly, both on the Windows-Settings-Microphone control panel.

Under “Allow access to the microphone on this device”, it must also say “Microphone access for this device is on”. If it says “off”, then use the gray “Change” button on the next line to bring up a switch to turn it on.

Then, in the next section, “Allow apps to access your microphone” the master switch must be “On” ( blue ). Once I realized these 2 settings are independent, a little experimentation revealed that either one set to “off” would kill Audacity.
Security 4 Audacity W10.jpg
Once I finally got the permissions “On”, further experiments with the devices toolbar showed that almost any settings would work.

Good Luck!

This is actually on a desktop. I don’t have a mic installed. very simple I am using two external speakers. I was actually using the software to cut an audio track out of one video to lay into another. I was able to do this prior to reinstalling window 10 after having hard drive problems. Now it does not appear to work as it did. I can record using the digital audio (s/pdif) setting, but cannot hear it through the speakers so not sure what it is recording. I have turned the mic setting on and off in both locations and it does not correct the error.

What is the exact error message that you are seeing?

I have attached the error code. I might have mis-titled this thread. The error does not happen until I press the record button.

I’ve re-read through this topic again, and I can’t see where you tell us what you are actually trying to record. For example: “I am trying to record the sound from a DVD playing in VLC media player”.

I am recording from windows media player from a video I recorded trying to capture the audio track. So just need the signal to the speakers.

My guess is that the audio in the video has a sample rate of 48000 Hz (which is common for video).

Try setting the sample rate for the recording and playback device to 48000 in the Windows Sound Control Panel, then launch Audacity and set the “Project Rate” (in the lower left corner of the main Audacity window) to 48000.

OK, I found the problem at least for my computer. When windows was reinstalled, it set the audio speakers to 5.1 surround sound by default. I do not have 5.1 surround sound i only have two stereo speakers. I corrected the setting to stereo and the error code vanished. The program works great.

Excellent. Thanks for the update.

I shall close this topic as “solved”.