Error -9985 Opening Recording Device

I’m on Windows 10 with Audacity 3.1.3

When creating and recording on the first track in a project, everything works fine.
When I create a second track and try to record it doesn’t work. Or if I create a rhythm track , it works fine, but I can’t get a second track to record.
I can only get I track per project to record.

The Audacity monitor works fine with my mic, so it is picking up the signal from my mic and interface (M-Audio 192/6).
But when I try to record on the second track, the little mic symbol on the task bar, which indicates Audacity is receiving from my mic, appears for about a second, and then it disappears, as do the lines around the red record button that indicate recording. Both appear briefly and then are gone, and sometimes I get the error message:

“Error Opening Recording Device
Error Codes: -9985 Device Unavailable”, n sometimes I don’t get an error message. Just little flash of mic symbol and then nothing - no recording.

But my recording device is available for the first track, and appears to be very briefly available for the second.

I do not have Skype opening in my Startup.
I have gone into my Windows Settings-Sound-Sound Control Panel-Recording and enabled ‘Stereo Mix’, as well as my interface.

This is relatively new. I recorded multiple tracks for years, then I didn’t record over Christmas (and there have been Windows updates). And just to make it interesting, two tracks did record once or twice, particularly when I Zoomed with a friend to get help and tried it to show him, and of course both tracks worked fine, but not since.

Any help with this would be appreciated. Thanks

PS: I forgot to mention, in Windows settings - Sound - I went into the Microphone Privacy Settings and turned on 'Allow desktop apps to access your Microphone" and Audacity is listed as an app that is affected by that allowable access.

You wouldn’t be the first person to have issues with trying to overdub with the M-Track M-Audio.

First, see if you can overdub with your headphones plugged into the computer instead of the microphone.

You may find you are unable to overdub with your headphones plugged into the M-Audio. Things to try:

  • If you haven’t tried WASAPI, try that.
  • Set everything to the same sample rate, e.g. 44100Hz: Set the Audacity Project Rate to 44100Hz (lower left corner). Start Windows Sound Control Panel: Windows-Key, “R”, “mmsys.cpl” (or Windows > Settings > System > Sound > Sound Control Panel). Playback Tab > Select the M-Audio unit; Properties; Listen > Turn OFF Listen to this device; Advanced: Default Format to project rate. Repeat for the Recording Tab. Also, check that all of your settings in Audacity and in the Sound Control Panel are either mono (1-channel) or stereo (2-channels).
  • Reboot your computer and/or start with a new Audacity project and a fresh recording.
  • Try installing a different Software driver.

Post back what you find.