Erratic volume and pan slider behavior while playing

Am having a couple of issues, maybe related, but driving me a little batty. I’m mostly using Mac OSX El Capitan, but the same problems are also happening in Windows, but much less frequently or severely, but happening in almost exact same way none the less.

When playing an audio file, trying to adjust the volume sliders (either in the mixer or on the track)and the slider will continue to move erratically or jump to extremes, even after I am no longer attempting to manipulate them with a mouse. Happens more frequently with the volume sliders but they will erratically jump up (not great on my ears) or really just jump anywhere, usually a couple of seconds after I have made my adjustments and released my mouse button.
Does a very similar thing on the sliders to the left of the track in the main viewer. But not only do the sliders erratically move, but the tracks themselves are constantly moving up and down, or when I try to expand the track view to see the fader pan sliders, (in a multi-track session, more than 3 or 4 tracks will collapse the track view where pan slider can’t be seen). It feels like I’m trying to chase the track or the sliders with my mouse. Often while grabbing the pan or volume slider with the mouse and moving it to where I want to adjust, a couple of seconds or less later the slider may completely jump to the other side or to the highest volume or reversed, etc. Very difficult to make volume or pan/fader adjustments while playing a track. The issue with trying to expand the track out to see the fader sliders will also occur even if the track is not playing. With nothing playing am trying to adjust volume and fader sliders and the tracks are auto collapsing and sort of “dancing” away from my cursor.
super annoying little issue and would love to find some solution.

What version of Audacity are you using?
– Bill

It’s the most current one I use day to day. Shows up as 2.13. I also have 2.10 and 2.11 as well as a couple nightly and debug versions, and the problem occurs on all of them about the same. May actually be worse on the newest version.

I hope those are typos for 2.1.3, 2.1.1 and 2.1.0. Otherwise you have rogue versions made by someone else.

This sounds similar to a bug that was introduced in 2.1.1 but was fixed for 2.1.2 It only affected the gain and pan sliders. If you held one of those sliders on one track while the screen scrolled, the corresponding slider on the other tracks would move at the next screen scroll. I cannot make that happen in 2.1.3-alpha.

Can you say what slider exactly you mean by the “mixer” slider? Do you mean Mixer Board? I tried opening Mixer Board on El Capitan but cannot see a problem. Can give more detailed steps that would help us reproduce the problem?

Have you tried Tracks Preferences and turn off “Automatically fit tracks vertically zoomed”?


not the best example, but a quick example video i just uploaded… usually its much worse. the more tracks seems to affect it.

autofit tracks vertically zoomed is off/not checked

As I said, 2.11 and the like are not supplied by us. Where did you obtain “Audacity 2.1-4.3” from?

I suggest you trash all your Audacity versions. Next, install an anti-virus app and run the most thorough check possible.

Then go to and install 2.1.2. Please follow these steps to install Audacity

Next, before launching Audacity, open Finder, choose Go > Go to Folder and type:

~/Library/Application Support/

Delete the “audacity” folder in Application Support. Now you will have fresh Audacity settings.

What mouse are you using (make and model number)? It could be you have a mouse lock setting operating.

Do not use the mouse scroll wheel when you are over the Vertical Scale unless you want to scroll up and down the vertical scale. If you scroll or zoom the vertical scale by accident, hold SHIFT and right-click (or CTRL-click) on the vertical scale to reset the vertical scale to normal.

In your video, it looked like you were moving the Mixer Board gain and pan sliders and the gain and pan sliders on the corresponding track were not moving. If so, that is wrong, but I cannot make that happen.