Envelope control points misplaced

In my current project, the Envelope tool control points appear where clicked in all tracks except one, wherein they incorrectly appear at the start of the track, regardless of where I click along the top border of the waveform. In the past, I would duplicate such a track, which solved the problem. But now the latter solution fails. Has anyone experienced this problem and found a solution?

I was able to replicate the problem by using the Amplify tool on a section of a clip. If I use the Envelope tool before the Amplify tool, the issue does not surface. So there might be a stability issue.

If you care, please zip up your project, upload it to a public file sharing service, then PM me a link. - I’ll look at it.

Have you tried Tracks > Mix > Mix and Render ?

See also this issue, which may be related. They're back. Envelope Control Points. Millions of them. · Issue #4070 · audacity/audacity · GitHub

Can you replicate this in a new Audacity project ?

So there might be a stability issue.

I updated to v3.2.5, anticipating the Envelope tool points issue to be resolved for me. Alas! The issue persists. Can someone run the following test to see if it is a bug or merely a peculiarity on my system?

  1. Generate a new project.
  2. Select the entire track and use the Amplify tool to set the peak amplitude at say, -3dB.
  3. Use the amplify tool to amplify or attenuate a section near the beginning.
  4. Now try creating Envelope points near the end of the clip.

For me, the Envelope points almost always appear at the start of the waveform if I use the Amplify tool BEFORE the Envelope tool.

Note there are no tracks to select in a “new” project.

When I "Generate"d a new “Tone” track prior to your step 2, I was unable to duplicate your problem.

Unfortunately, I have seen little to indicate the developers have addressed outstanding envelope point errors, however, it may be worth checking the current 3.3.0 Alpha nightly build to see if you still have the same issue: https://nightly.link/audacity/audacity/workflows/build/master

Note that alpha builds include experimental and untested code and should not be used for production work.

Sorry for not being clear, by new project I meant to say a new audio clip, like an imported Wav or MP3 file. The issue I describe never surfaced in earlier versions, and it occurs about seven times out of ten for me. The problem only occurs after using the Amplify tool, so the two tools seems to be in conflict a lot of the time.

Thanks for running the test. Glad you don’t experience the problem.

You are welcome. :grinning:

It is entirely possible that you are propagating a glitch from a older project. One thing you can try is to export tracks from that old project to .WAV; then start a brand new project, and import the .WAV file. This could clear your issue. If you copy a track from a broken project directly into a new project, you may be bringing the old glitch into the new project.

What you say makes sense to me. Thanks again.