Enabling input devices.

I just installed audacity on to my laptop because I want to record webinars and other playing audio.
I installed audacity 2.0.2 onto windows 7.

I was following the tutorial to get the correct input device:

Windows Control Panel for sounds

Windows Vista and 7 computers almost always only have microphone inputs enabled by default. Earlier Windows systems may also need the input for recording computer playback to be made visible before Audacity can use it. To show or enable inputs, launch the sound device control panel from the Windows Control Panel or from the system tray (by the clock).
Windows Vista and 7
Right-click over the Speaker icon by the system clock then choose Recording Devices to open the Recording tab of “Sound”.
Right-click anywhere inside the Recording tab and choose “Show disabled devices” then right-click again and choose “Show Disconnected Devices”.
Right-click specifically over the input device you want to record with (in this case “Stereo Mix” or whatever alternative you have), and if visible, choose “Enable”.

my problem is that once I show disabled and disconnected devices…I don’t have any more devices. I have only my microphone and nothing else. What am I supposed to do to enable recording off the web or other playing audio?
I’m attaching a screenshot just so you can see what I’m talking about
Please help me soon; the thing I want to record is in a few hours.
scrn 030912.png

It may not have been worded strongly enough in the text, but some computers can’t do this. You follow all the instructions and the software just isn’t there. For you there’s the software and processes at the bottom of this series of instructions. If you’re on a laptop, chances are good that the loopback cable isn’t going to work and you need to add or buy additional software.


Self recording is not a guaranteed service like recording a microphone or listening to YouTube and some increasingly large number of computers just can’t do it by themselves.


I see, guess I just didn’t read enough of the tutorial.
Then I found this


thats exactly my problem, and I guess it can’t be solved.

I guess it can’t be solved.

Or, the latest versions of Windows do not include the mistake that was included in the earlier versions.
Windows laptops are business computers. Stereo-Mix can create problems with corporate conferencing. Most Macs can’t naturally do this, either for stability reasons.

I’ve used Stereo Mix on many XP machines over the years with absolutely no associated “stability” problems.
I currently use Linux, which also has the ability to “play through” and again without stability problems.
So I wonder if it really is “for stability reasons” or because Apple think that it’s too difficult for Mac users to cope with?
Microsoft seem to be following the Apple trend of dumbing down computers to the level that “if you can’t buy an App to do it, it can’t be done”.

You didn’t. The bottom of the tutorial lists other apps you can use:
http://manual.audacityteam.org/o/man/tutorial_recording_computer_playback_on_windows.html#alt .

Once again it is not Microsoft who remove stereo mix, but largely the choice of the computer and/or motherboard manufacturers.

Microsoft (under the WASAPI API) explicitly provide a method on Vista and 7 for applications to record computer playback even if the sound device does not support stereo mix recording, but Audacity cannot use that method because it does not support WASAPI.


Thank you for that. In fact after posting that message I went through them. I was hoping for some freeware- unfortunately none of the ones listed worked for me so I just ininstalled them.
I will try exploring other options.

SoundLeech is currently free (even though it is listed as “evaluation”). The interface is a little bit strange but it worked well when I tested it.

[I know this is an audacity support forum, but I’m still hoping you can help]
problem with soundleech:
I start it, then start a program to run audio eg, windows media player or firefox or something. No balloon comes recognising a program playing audio and when I ‘stop leeching’ nothing has been recorded.
can help?

Assuming that you have SoundLeech running in the task bar, right click on the icon and enable “Start Leeching”.
(also check that the “capture folder” is writable).

I know I’m asking for help for some really basic problems; however I’d like to think I’ve read enough techie jokes that some things are not a problem for me.
The steps I took with soundleech:

  1. I installed it.
  2. I changed the capture folder to my desired location which is fully writable.
  3. I pressed ‘start leeching’
  4. To test, I opened windows media player and firefox; I played audio in both.
  5. No balloon popped up to name either wmp or firefox, therefore I assume they were not recognised.
  6. I pressed ‘stop leeching’
  7. On the chance that recording had in fact occurred, I pressed ‘show captured files’
  8. The folder was empty.

nevertheless, I am still grateful for the time and help you’ve given me so far. I hope the above clarifies my actions.

thanks again

I hope that I was not appearing to be patronising. We only know about what you do from what you write, so I could not assume that you had taken the necessary steps to activate SoundLeech. Unfortunately I am unable to help you with SoundLeech as it is not our product and I don’t know the details of how it works. All I know is that I’ve used it and it worked straight away with the steps described. On Vista/Win 7 it may be necessary to reboot (not required on XP).

No thats okay, I do understand. I should have been more clear in my previous message.
I’ve done everything I can think of… I’ve sent the creators a plea for help. As for the rest of it, I’m tired. Its come down to asking if anyone else managed to record the webinar.

…everything worked fine on my old computer…tears

thanks to everyone in this thread for the help you’ve given me

I found SoundLeech temperamental at first on Win 7 x64. I did have to reboot, and it would not record until I had actually chosen a different capture folder than the default.

But now it works fine even after rebooting and changing the capture folder a few times.

Also it allows you to not hear what you are recording but still record, which you can do with stereo mix sound card recording on XP, but not on Vista and 7.