Electrical Whistle in Recording

Dear people,

Sometimes there is a (electrical?) whistle in my recordings. I’ve attached an example file.
I am wondering how it’s produced and even more curious how to eliminate it.

I’ve tried a low-pass filter and noise attenuation, but it alters the sound quality.

I’d really like to hear from you :slight_smile:


Unfortunately that didn’t work. Perhaps this will help: https://forum.audacityteam.org/t/how-to-post-an-audio-sample/29851/1
Please post a short WAV format file.

Crossed posts :slight_smile:
A short WAV file would be better as MP3 encoding makes the problem less clear.

Like this?



Haha Steve, yes we’ve crossed posts. Here’s a link to the WAV file:


Ha Koz, it is bit different than the sound I hear in your recording!

Thanks for your time and help!

The main problem is that the first voice (Skype?) is badly damaged by excessive processing - probably “noise reduction” and / or “echo cancellation”. Unfortunately that can’t be fixed.

The second problem, which is probably a side effect of the above, is the whistling sound in the left channel. You can see it here (the wiggly red / blue line that runs from left to right in the upper track) in the track spectrogram view:

First Track000.png
As you can see, the frequency of that whistle varies, which makes it very difficult to filter out. In my opinion, the best solution would be to “split stereo to mono” and delete the left channel (click on the [X] in the top left corner of the track). The result will be a mono track without the whistling.

Thanks a lot for showing me that ‘spectogram view’! I was already looking for the frequency spectrum, but wasn’t able to do so.

Yes, when you delete the left channel it gets much better. To refer to your first point, this is the original/unedited recording of the audio file.

Do you see any chance/tips to improve?

Like to hear, many thanks!

Can it be a hardware issue? For example a damaged or low quality mic?

Or maybe electrical interference? We did put off our phones while recording, the two mics were 2,5 meters seperated

I’d suggest:

  1. Split to mono
  2. Delete the upper (“left”) track
  3. Amplify the entire track to about -1 dB
  4. Filter Curve EQ” with the “Low roll-off for speech” preset.
  5. Select a part of the recording where there are no voices or sounds other than the background “hiss”
  6. Get the “noise profile” with the Noise Reduction effect.
  7. Apply gentle noise reduction - better to leave a bit of hiss than to create “over-processing” artifacts.
    I’d suggest setting of:
  • Noise Reduction: 16 (or less)
    • Sensitivity: 6
    • Frequency smoothing: 3

My result:

What is your setup? How are you doing the recording and what equipment are you using?

It is much better now! Thanks for your help!

I use this setup: https://www.amazon.co.uk/SubZero-BASE-2-Interview-Recording-Bundle/dp/B07FNJ6GKV

We put the laptop 3 meter from the microphones. Also we make have maximum space between the two mics.