ElCap Error while opening sound device etc

Hi all im running first tests on elcapitan 10.11.4 and audacity 2.0.6 then 2.12 throws up the “error while opening sound device” Ive followed the wiki advice and matched up all sample rates on builtin out and mic input with audacity and tried all the software hardware monitoring on offs and get nothing but get this message in playback or record in even a blank project. I even had a go with soundflower and got the same. Also drag and drop doesnt work but i see a few others have that problem but import does work slowly.

Ho hum anything I may have missed I realised ive never been here before as Audacity has just worked since time began - I have a mavericks install on the same computer that still works

thanks in advance


The FAQ about it is here: http://manual.audacityteam.org/o/man/faq_errors.html#sound_device.

You could try rebooting the computer.


Thanks for this but that was my first port of call and no pref changes have any affect. I get Recording device not available and Playback device not available
warnings. I also get the same using my focusrite scarlet 4-2 audio interface in audacity but that uses coreaudio not its own driver and I will try a firewire
device with its own drivers later. Also Ive found the built in output/input doesnt work with QT7Pro either but does with QTX . Protools my first tested tool
worked straight off which is ironic given it was usually the reason i waited a good year before suggesting upgrading OS’s and my main audio work machine is snow leapard.

My next move without any more suggestions is to do a clean elcapitan install instead of the mavericks clone ive tried so far. Ive read online that both Audacity and QT7 are being used within elcapitan but there do appear to be more random problems with it than ive seen in a long time.

thanks to anyone who can advise


“Device not available” is not an Audacity warning as far as I know. If so, the Mac is showing you that message.

Are you quite sure Audacity project rate and Scarlet input and output sample rates as shown in /Applications/Audio MIDI Setup are identical?

Have you tried quitting ProTools before using Audacity?

If you cannot solve it, please post the information from Help > Audio Device Info… top right of Audacity. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1

Audacity 2.1.3 when released is likely to be the final version for Snow Leopard.


Thanks again for coming back I thought I should post my success on a clean el capitan install - Audacity works with no need for any special settings on built in
output and other interfaces. I had checked in the audacity window info you pointed me to and saw no sample rates listed - following this I tried the osx console which crashed and wouldnt reload hence the reinstall. I can only guess a problem with older coreaudio from a corrupted download or updating mavericks but thanks again.

I checked my main snow leopard work machine and im still on 2.06 as it works fine for me

Only unsorted problem was the lack of drag and drop to audacity windows others report but dargging to the app icon does that ok fine for me

thanks again


Which Protools version are you using?

Older versions came with a kernel extension that took complete control of Core audio. It was there to prevent stuttering in Protools, but often produced problems in other audio apps.

I’m not sure that kernel extension even works under El Capitan. But I don’t know anyone brave enough to try Protools under EC :laughing:

Hi thansk again but my problem wasnt protools related - the PT controlling audio devices issues went away with certain drivers and old versions/devices except for PTHD interfaces where it is a neccessity - but for elcap PTv12 is the only sensible answer which is why i personally stick with Mavericks which works for 10 and 12. These new machines im doing tests for before installing come with elcap hence my tests - Im assuming my problem was either a corrupt upgrade or just doing an upgrade instead of a clean install as it was obvious problems were in older programs like QT7pro and Qlab2 some other older editors all of which use apples coreaudio drivers and Audacity for instance didnt see any sample rates available so no wonder it wouldnt do anything.

I dont recommend anyone going up OS systems for PT unless neccessary for other software but I suspect that will be neccessary more and more.

Congrats on the VST realtime plugin development - my older machine was still 2.0.6 so i hadnt even noticed but having taught it for journos a few times its a bonus

I still dont get drag and drop but dragging to the icon and then a quick cut and paste works easily enough for a creature of habit like me


I feel your pain…

I’ve just erased my El Capital test install to start testing on Yosemite. It’s not that there are a lot of problems with audio on EC, it’s just that they don’t surface for everyone and I can’t solve them.

ATM, I only have one machine, a brand new MB Pro i7 15" 2016 that still occasionally hicks up, dropping the connection with a Motu 828 mkIII. I’ve coerced Apple into exchanging the hardware, because an exact clone on another identical machine behaves well. Of course, clones these days aren’t exact clones, as keys are derived from stuff like hardware serial numbers, so I guess there’s always a difference when it comes to the cloud.

Yosemite is stable, up to now. I’m on Mavericks myself, but that’s no solution for new hardware. I also never seem to have problems. There’s just one thing with Yosemite atm, but that’s not audio related. It is a real pita, however. Yosemite insists on logging me out when sleeping, despite this setting being off in system prefs. But I’ll check that one of these days…

To clarify, there is no OS called El Capital, it’s El Capitan.