effect failed to initialize

I just down loaded version 2.3.3 and when I try to open it I get a pop up saying several effects failed to initialize and the program won’t open. I tried uninstalling and reinstalling and no luck… can anyone help?
Screenshot (129).png
Screenshot (130).png

Click the “OK” button. Can you then run the effect?

Nope… same boxes just keep popping up over and over. program won’t open

Do you recognise what plug-in that message is referring to?
Which version of Audacity did you have before updating?

I’m guessing those plug ins are ones that I’d added… and far as the version I had previously, noot sure what version it would have been, but I’d used it for a couple years

With Audacity closed, open the hidden folder:


and delete the three files:

  • audacity.cfg
  • pluginregistry.cfg
  • pluginsettings.cfg

Then launch Audacity.

that did it, no idea what the issue was… but that worked… thanks!

using Audaciyt 2.42
same problem
did the above. still get the error message “effect failed to initialize”

Which effect?

Hi Steve, Thank you, i have the same issue. The error is like “effect failed to initialize SC4”. Not sure what is SC4. The error started after i upgraded Audacity to version 2.4.2.

Update: I guess my issue “effect failed to initialize SC4” is resolved.
SC4 was a plug-in from old version. After Audacity update to 2.4.2., somehow SC4 remained enabled as yesterday i was able to find it when calling the macro insert function, but it was throwing error messages like 4 times one after the other. Today i checked Plug-ins (Generate → Add/remove plug-in…) and found SC4 and some other plug-ins like EQ as Disabled. So i thought if this is disabled, it shouldn’t throw error. I went again to Insert function of Macro, this time didn’t find SC4 there and so no errors. Thanks