When I open Audacity my computer has an echo. It picks up my voice or any sound or tap on the computer. If I bring the mic level to zero, there is no echo but it won’t record either. I wish to record songs from an old cassette player. How do I remove that echo?

Turn off “Software Playthrough” in the “Transport” menu.
What are you trying to record, a microphone or a cassette player? How is the mic or cassette player attached to the computer?

There’s some information here about connecting cassette players:

“I tried turning off the Software Playthrough but it did not help. The computer still “hears” any outside sound. I am
trying to record from a cassette player to my computer using an analog to digital converter through a USB port. The odd part is that I was able to record previously using Audacity and the converter. Then one morning I attempted to record and this problem popped up.
The echo exits whether the converter is attached or not.”

I’m guessing that you are using a laptop computer and Audacity is using the built-in mic as the input.
In the device toolbar, set the recording input to the USB option.

My device tool bar has the following: MME; Microphone (Realtek); 2(Stereo)Record and Speakers(Realtek High Def). I checked all of those drop downs and none shows a recording input USB port. You are correct that I am running a laptop. Am I looking in the wrong place.

By default, Audacity only looks for devices when it starts up. If you connect the USB device while Audacity is running, Audacity won’t see it until you “Rescan Audio Devices” (in the “Transport” menu). Alternatively, connect the USB device first, wait a few moments for Windows to find it and connect to it, then launch (or restart) Audacity. The USB device should then be listed as a recording device in the device toolbar. Ensure that the playback device is set to the sound card that you use for listening (probably the Realtek unless you’re using USB speakers).

I am NOT using a microphone. I am recording from a cassette player to my laptop using a analog-to-digital converter that attaches using a USB port at the computer. The “Software Playthrough” is off…doesen’t help.

NOTE: this echo effect occurs as soon as I click on “Click to start Monitoring” even when I’m not trying to record…no input device of any kind. I just open up Audacity, Click to start Monitoring and the sensitivity starts showing up in that box with the slightest sound.

Sound from where? From the USB cassette device or a sound in the room, such as you talking?
If you tap the case of your laptop, do you see Audacity’s recording meters respond to the sound of the tap?
According to your first post, yes the meters respond to the sound of the tap. How is that sound getting into the computer? Answer: it’s getting in through the built-in microphones in the laptop.

Have you tried what I suggested in my previous post? What happened?

Sorry Steve, I may have described the problem poorly. There is no actual sound “echo”. When the Recording Volume is at 0.00, the Recording Level shows nothing if I talk or tap the labtop. But if I turn the Recording Volume to even the slightest reading (0.02), the Recording Level picks up my voice or any other sound including a tap on the laptop. There is NO microphone or other input device attached.

I bet your laptop has a built-in microphone. Look in the Windows Sound Control Panel at the “Recording” settings.