Echo in playback of recording / no click removal

On older version (2013) burns came out perfect, but on updated version 2.4.2, the music sounds like an echo chamber and click removal, has no effect.

Are you talking about “recordings”?
What have you recorded and how did you do that?

Yes, from phono, used a headphone jack to pc, recorded, & heard the echo effect right away on the monitor speakers.

Were you hearing the echo while recording was happening, or on playback after recording had completed?

On both, I can only think to turn down the stereo monitor speakers, which may be providing feedback to the pc, & do a sample new recording, or try another app.

What exactly are you recording?
What equipment are you using and how is it connected together?
What settings are you using in the Device Toolbar?
Is “Software Playthrough” enabled? (it should normally be off / disabled / not selected)

Problem Solved: Simple Driver Update placed a patch in the soundcard (as Windows update sometimes wont pull that) & the echo was gone. It came back only when recording, so turned off mic, & changed the output to digital audio, & it worked.

Problem Solved: Simple Driver Update applied a patch to the soundcard & the echo was gone.
Would not echo on trial run, only on record, so turned off mic, & changed output to digital audio,
& it worked bothways with no echo.