Echo in my playback

Hello Audacity Members.

I am using Audacity 3.1.3 on a Windows 10 Asus Laptop. My equipment consists of an Audio-Technica AT2020 mic mounted on an On-Stage Shock Mount MY410 fixed to an On-Stage Bass Drum Boom. I have built a sound area, my transformed cupboard, with heavy quilted padding stapled to the walls.

Can anyone help me remove the echo, chamber background sound I am still getting?

Thank you
Audacity setting July 3 2022.JPG

Noise reduction won’t work.

Make sure you’ve selected the correct [u]Recording Device[/u].

…If you choose Stereo Mix or WASAPI (loopback) you are recording the output from the soundcard and under certain conditions you can get a feedback loop and an echo.