Drums on every track.

I can not put down a track without the Drums recording on every track. I’ve tried going through the preferences and
tried changing things around a bit , but can’t get rid of the Drums. Am I not using a setting I should be. Can’t figure it out. Any ideas? Thanks.

So as I read this:

You have drums as a backing or rhythm track and the goal is to play that to your headphones while you perform other instruments to other tracks. Are the drums a real track on your machine? The problem is the drums keep being recorded in addition to the second instrument. Did I get it?

You are on headphones, right? Wired?

In the Audacity recording device (microphone symbol), make sure you’re recording from something you can reach over and touch. A real thing. When I do this, I record from “USB Audio CODEC” which is the name of my Behringer UM2 interface. That’s it on the left. It’s real.

If you like to record internet music or other shows, chances are terrific you’re not recording from a real thing. You’re recording from a software redirection program or app.

What is your microphone, interface, or device and how do you have it connected? What does the Audacity microphone symbol window say? Describe the performance.


Yes on the first. The drums are on track 1. They are recorded from a drum machine through my interface/ Moukey MSc1. When I record guitar on track 2 , the Drums record again with the guitar. Yes on the wired headphones. I have a voilamart bm-800 microphone/ moukey MSc1 interface going through windows 10.
Everything works fine , I just get Drums on every track.

Good detail. We need to read that again and see if we can figure out where it’s coming from.


@Koz, haven’t we seen a previous post about a moukey MSc1 interface feeding back the output to the input?

@Koz, haven’t we seen a previous post about a moukey MSc1 interface feeding back the output to the input?

Oh, right. Same problem, same device, and same poster. Resolved by changing the interface.

It must be something with the device. I hooked up my behringer umc22 and it works fine.


Moukey MSc1
I apologize for being a little slow at this. It is new to me.