Dropped Hard Drive - Recovering AU Files

Hi guys,

I’m hoping to recover the audio from an Audacity project. The circumstances around this recovery are complex - but, suffice to say that I was able to retrieve the SessionData from the unsaved project, and now have a whole directory of .au files.

The Audacity manual says I can recover a project from these files by importing them:

However, when I try to import the files, Audacity says it doesn’t recognize the format, and recommends I install ffmpeg. Doing so has no effect.

I’ve also tried Audacity Recovery Utility, which spits out some weird error upon trying to recover the files:

Traceback (most recent call last):
  File "audacity_recovery.py", line 157, in ?
  File "audacity_recovery.py", line 92, in MainLoop
ValueError: invalid literal for int(): 000003a

I’m not even positive these .au files are from the right project, so I’d just like to be able to listen to them and determine my next move.


Winows 10 Pro N 1803
Audacity 2.2.0

The circumstances around this recovery are complex

Can we assume you can’t find the AUP file?

Was this an edited project? Were you in the middle of editing or production? If so, you no longer have a show or any automatic path to recovery.

The AU files are six-second snippets of music or sound. You should be able to play them in Audacity.

The AU files alternate Left/Right in a stereo show, so you may find snippets that are almost identical. They are probably a Left/Right pair.

If you have a good idea what the show was, it might be possible to reassemble the snippets manually.

How long was the show?


I just selected an AU file > Open With > Audacity 2.2.2 > Enter.

And it played.


I’m editing on another program - I only used audacity to record my own audio. I’m attempting to recover that project so I can get my audio back - as I already have backups of the raw audio for the podcast guests. So no, no .aup file involved.

I’m willing to re-assemble the snippets, but I still can’t get Audacity to open them. I tried ‘Open with…’ as well, and still get the same error message (attached).

I’ve also attached one of the .au files in question. Is there something wrong with it, perhaps?

Thank you!
e0000aea.au (1.01 MB)

That .au file appears to have a valid file name and a valid size, but no valid data. Every byte is zero, so there is (literally) nothing to be recovered.


I already have backups of the raw audio for the podcast guests.

In perfect quality WAV, right?

It’s highly recommended that you Export raw WAV backups of yourself.

no .aup file involved.

Since you’re already into the weeds of Audacity structure:

This is an Audacity Project example.

The AUP (text) file tells Audacity what to do with all that stuff in the _DATA folder. Typically, you double click the AUP file and Audacity will automatically present your show. You apparently have the shards, fragments and debris of a badly failed Project.

Projects can let you save your editing structure and environment (but not UNDO) and are really handy for stopping in the middle of a show to take a rest. The disadvantage is what happens during an error.

Sometimes you might be able to rescue a mono sound recording without the AUP manager file. You might be able to partially rescue a damaged stereo show and if you start editing, that’s the end of the world. No rescue past doing it manually, opening one AU file at a time.


In perfect quality WAV, right?

I’m not making that up. MP3 files come with built-in sound damage and it gets worse as you do production.

Good editing hygiene says have perfect quality WAV files of all your work available against the time the dog eats your laptop. It may not make any difference now with a home podcast, but if your work takes off, this becomes more and more important.

People write me checks to do this stuff and I’ve never lost a production recording because of machine failure or other accident.

Saving it is good, too.

“The Producer called. She wants to know if you kept a copy of that interview you shot last year.”
“Sure. Get their cloud address.”


Missed a step.



Yes, I know mp3 is a compressed format and not used for editing. Hence why I edit WAV files.

I’m actually a video editor by trade - and get paid as well. I understand redundant backups and usually have them, but sometimes mistakes happen. This was a personal project I hadn’t copied to a 2nd drive yet.

My guess is the AU files are empty because I ‘undeleted’ them from their temporary folder using TestDisk - for anyone interested.

I ‘undeleted’ them from their temporary folder using TestDisk

I believe you. I’m not a Windows elf.

Sorry for your loss.