Dropouts when recording improvements

Long time Audacity user. Currently using version 2.4.2 on an old Mojave machine strictly for ripping vinyl

Very occasionally I get what seems like single buffer dropouts, and I’m trying to improve that.

My setup is…
Input: Turntable → Rane 70 mixer → USB to mac
Output: mac USB → SSL 2+ interface → speakers

I’ve tried most everything I could think of.

  • I’m not running any other programs
  • I’ve got audacity graphics at lowest settings (ie only updating meters 3x / second)
  • I’ve set the buffer in audacity to an extreme setting, 6000 ms, but this doesn’t make any difference. I say this because when I put the needle on the record, there is NOT a 6000ms delay
  • Recording format is just at 16 bit
  • The RANE is hard-set to 48k, so I’ve tried setting my audacity project to 48k, no difference, still get the drop out occasionally

I do have software playthrough on because I need to listen to the rip to make sure there are no glitches.

Does anyone have any suggestions?
Would disabling the software playthrough make a huge difference? I’m open to that if there is another way I can monitor what is coming in, ideally via the computer. I’d rather not bypass the computer for monitoring, I still need to listen for glitches.

Thanks for any tips yall have - I’m mostly curious why the ‘buffer size’ setting seems to have no effect.

What’s the machine and how old is it? When was the First Birthday?

Output: mac USB → SSL 2+ interface → speakers

Can you listen without using a USB service?

Do you have a spinning metal hard drive or Solid State Drive?

Do you have an iCloud connection or any internet connection while you’re transferring work?

but this doesn’t make any difference.

As I’ve posted in other messages, it helps us if you can make it worse. Any change you can force, either direction, is valuable to know.


Thanks a lot for the reply, I really appreciate it.

The machine is admittedly old, late 2008 MacBook. Its a champ though, when I run my DJ software it handles multi-channel input decoding and output rendering just fine. I assumed 2-channel input would be fine.
I do have internet active, maybe I should disable wifi during ripping? I had tried disabling any network activity on the machine but I could have missed something.

I’ve not actively tried to make it worse, but that is such a good suggestion though, thanks for putting that thought in my head.

The thing is none of my changes seem to have any effect, better or worse. The buffer size in audacity not seeming to matter is a really big point of confusion for me. Also, Audacity’s drop out detection doesn’t fire with these particular dropouts (I have been able to trigger that in other ways), makes me think it could be the transmitting hardware in that case?

Other things I’ve tried, hiding the audacity window, zooming out very far on audacity waveform, zooming in to the beginning so it doesn’t have to draw the waveform.

I’ll try disabling internet completely and see how far that gets me, this is a really tough one to track down.

I appreciate any further insight. Thank yall :mrgreen:

Oh forgot to mention - solid state drive, brand new. Max ram (8gb), also brand new.
And it’s technically a Macbook Pro.

Sorry for the multi-replies, I can’t figure out how to edit a post.

I can listen without USB just via the mixer and playback is perfect.

Also, I have wifi disabled, I’m ripping right now, and I got a glitch. So it’s probably not wifi related.

I can’t figure out how to edit a post.

Do Not edit your posts. Edited posts—reading backwards—are impossible to follow.

I need to go back and read that again.


solid state drive, brand new.

So you’ve been messing around inside your Mac? Did you take a vacuum and soft, clean paintbrush to your fans and vent channels? Keyboard?

Do the glitches occur in exactly the same time every time you play the work? Can you find the damage by zooming?

It’s not that unusual for the playback service to cause problems and the show is fine. In that case the damage may wander around.


Oh yea I have definitely been in there messing around. This is not my first refurb. I did thoroughly clean it out when I was doing the replacements.

The glitches do NOT occur at the same time. Usually what I do i when I catch it, I just restart the entire side. 90% of the time I will be able to get through it on the second try. Zooming in on the waveform is how I am sure the error is on write, because there is a very small section of pure silence. I haven’t measure it precisely to determine if it is some expected number like 128/512 etc…

This again begs my question - at what point does Audacity’s ‘buffer size’ come into play? Like I said, I have it set to 6000ms but playback is almost instantaneous…definitely not 6 seconds behind. If anybody wants to go on that tangent, what exactly does ‘buffer size’ do in Audacity if its not input and its not output?

Now a small update, tell me if I’m crazy here… but I think I just noticed the glitch occurring just as my AC unit cut off. Now they are not on the same circuit, AC is dedicated as expected, but definitely in the same house and this room is close to the unit.
I will definitely do some science to try and prove this is related, but it would make sense to me.

If it is a power problem, what would be a good solution? I’m running off a standard surge protector right now, I could do something like a rack power conditioner or something I’m just learning about called an ‘uninterruptible power supply’. Would either be better or worse? The rack units are designed for audio components and the UPS units seem to be designed for computers, w/ battery backup etc. Do yall think either of those would help?

Thanks again!

The glitches do NOT occur at the same time.

Not what I meant. If you do a capture with an error, does the capture’s sound file play the error at the same time every time.


Scroll down to Latency > Buffer Length.

If you’re in the US, you might invest in a simple wall power checker.

I lived in two houses with wall outlets wired wrong. Nothing will screw up power line conditioners faster than having the wall wiring wrong. It’s not exhaustive. The results are tilted. If it’s says everything is OK, it’s probably OK, if it says it’s broken, you should stop using that outlet—now.

Surge Protectors are designed to protect your equipment if lightning strikes the power lines by your house. That’s pretty much it. If the lightning strike is powerful enough, it will lift the house ground/earth connection and fry everything anyway.

Uninterruptible Power Supplies come in two general versions. The cheap ones that run the client (you) from the wall until something goes horribly wrong and then quick as a bunny switches to battery backup and hope nobody notices. The much better ones run the client from battery all the time and the only thing that happens during an outage is the battery stops charging. No switching, no interruptions, zip.

Which turntable?


A word on grounding. The turntable cartridge and arm are almost certainly connected to the air conditioner. Did you connect the slender black wire from the turntable to the phono amp or Phono Input of the mixer? Analog turntables have three wires, not two.

Most of the turntable hum and buzz goes away with that thin black connection. The connector looks like a tiny two-prong fork.

Screen Shot 2020-10-13 at 6.36.01 PM.png
That puts the turntable ground on the shield of the mixer or Phono Preamp. If the mixer has a three prong power plug, that puts the mixer case on the house safety ground system. Unless you have a 220 Volt A/C system, that connects the house safety ground system to the body of the air conditioner.

I wouldn’t be shocked if the A/C kicking on and off can be heard. Another odd piece of this, bass notes don’t fit in a record groove. They don’t. So they are suppressed before vinyl pressing and they’re boosted back to normal in the Photo Preamp. That’s the RIAA system. The boost also includes all the bass interference in the turntable system. That’s where hum lives. That’s another reason for the third wire.


Yes, it plays back the same every time and it is visible in the wavefile too. Screenshot here:

I measure it to about 3768 samples, which doesn’t seem to hold any relevance to me. Had it been 4096 maybe, but thats too long, and 2048 is too short.

Thanks for the link, I’ve read that, and I understand what a buffer is and how it works, hence my confusion - because it doesn’t appear to be doing anything. I have it set at 6 seconds and I’m getting recording and playback almost instantaneously. I can’t see/hear the effect of buffer length anywhere.
Is buffer strictly for offline processing?

With regards to my hypothesis about the AC, turns out that’s not the culprit. I just started a rip with the AC unit turned off, and I’ve already gotten two glitches. Could still be another power issue but nothing obvious.

Which turntable?

Tried and true Technics 1200 mk5. I’ve used this exact turntable to rip hundreds of records into a different setup and she runs like you’d expect - perfectly. To your most recent post, this particular turntable has been internally grounded, for better or for worse.

The glitch is definitely digital, I’m just on a new setup, so I was looking for general advice I might have missed to improve signal flow into this old machine. I will probably try a different surge protector and get a nice power supply anyway to continue to eliminate variables. I’ll also try ripping to a different computer. It’s frustrating cause nothing seems to make a difference, and it would appear this thing is more than capable, its just that 0.001% failure rate that is killing my rips.

Thanks again

And just to be clear, there’s no hum at all. Just a short chunk of digital silence that is very inconsistent and almost impossible to recreate on purpose.

A little background so you know where I’m coming from…
I am in Texas. I’ve been a DJ for years (I have 7 technics tables, various models), repaired, designed, and manufactured audio electronics, and I write audio software for a living. So feel free to get as technical as you’d like. Also I actually used to do electrician work and I’ve replaced these outlets - they were backstabbed when I got here but I’ve connected them properly now. I still wonder if dirty power could be playing a part - the fact that Audacity doesn’t detect the dropout tells me its nothing in the computer itself, but I’m definitely not informed on how that dropout detection works.

I’ll try to keep this thread updated and I’m still open to any and all suggestions / illumination on my questions regarding audacity’s buffer setting and dropout detection.

Thanks yall

Technics 1200 mk5.

I did the survo mods for a number of 1200 Mk2 machines (from fuzzy memory). The company posted resistor changes that made the platter not fight you when you were trying to slip-cue. I wouldn’t know, but the DJs seemed to like it.

short chunk of digital silence

If you drag-select some of it and Effect > Amplify, what does the panel say? You may get different numbers depending on where the hole is coming from. The analog side may not get any quieter than -70dB or so. The digital connection may come in at -96dB (16-bit limit) and if Audacity is somehow making that damage the panel may look like this.

Screen Shot 2020-10-13 at 8.37.28 PM.png
Audacity converts everything to 32-bit floating before it does anything. That’s to give a super noise floor and an impossible overload/clipping value.

You should put the buffer value back at 100mSec. If you don’t, we may be fighting two problems: the original dropout and your wacky setting.

You mentioned you put new memory in. Have you ever done a memory test? Audio software is in a very tiny list of software that uses “high memory.” You can do XL spreadsheets and Photoshop edge blur all day long in perfect health, but the instant you run something that takes large bunches of memory, you could touch a bad cell and cause all sorts of troubles.

I have used MemCheck. When I did it, it ran from a floppy to take the smallest footprint possible, and then it would check everything else. Run it all night. It would cycle through many different tests with cutsie names. Checkboard, Flash Ones, running aardvark, rippling dixie, etc. Each one is a different pattern of 1’s and 0’s written to memory and even if you run it all night, normal, healthy memory should crank through all this without breaking a sweat.

But sometimes:



Thanks for that bit of info. I can’t find MemCheck specifically but I found one called MemTest86, I’ll try that and see what it says.

So are you saying there might be a different kind of RAM I could try if these tests fail? What would I want to search for?

Depending on the OS and version, you may have one built-in. If it fails, then you put in broken memory. Those different tests load in different patterns of data and then check for data addressing, data fade, leakage between cells, leakage between banks, etc. The last time I tried it with a currently available program, the test ran once, dusted off its hands and said “Everything Is Perfect.” No, dear, you have to do multiple passes. I haven’t built a machine in along time, but that’s the idea. You may no longer be able to do that.

What did Effect > Amplify turn up?

You’re in the level of testing that assumes normal testing didn’t turn up anything and you can’t intentionally make it better or worse.

Another testing technique is split the system in half (or fractions) and test each fraction. That gives you the Venn Diagram result.

Screen Shot 2020-10-14 at 1.46.34 AM.png
The outer balls can be your turntable, your interfaces, and your computer. If you’re really having a bad day, only the middle is bad. The combination of your turntable, and your interface, and your computer is needed to produce the damage. Borrow a different computer.

The machine doesn’t have Skype or Zoom now. Has it ever?

There are other way-left-field problems possible as well. You’re not the only user on your machine. The hole is the Other Entity periodically trying to check in. You can sometimes find those with Desktop > Go > Utilities > Activity Monitor. That’s how I once (recently) found a supervisory software licensing program replicating itself and taking up the whole machine. Literally 99% of the memory. I can’t tell if that was intentional or not, but it was a wake-up call. Turning over a digital rock.


I really appreciate this knowledge you are sharing. Thanks.

First a question, when you say ‘high’ memory, do you mean ‘high density’ memory? I’ve found some online that def has a higher bandwidth than the others, is that what you mean?
If not, what should I be looking for in memory good for large chunks of audio?

Yea, so the first program I found won’t write to usb for some reason, so I found another one called ‘Rember’, and I’m in the process of running that test 255 times. 5 successful tests so far…

Haven’t had a glitch again but next time I do I’ll turn that up. It really does seem to be pure digital silence, like a glitch in write vs a weak analog connection fizzing out.

I will try a different computer for sure. This computer is pretty virgin, and dedicated to vinyl. I only have the DJ software (Serato) and audacity, that’s basically it.

Yea that’s one of the first things I did, but I didn’t see any spikes or processes corresponding to the dropouts.

‘high’ memory, do you mean ‘high density’ memory?

No. In days gone by, programs could only address memory up to a certain limit. Anything beyond that and the program was expected to start shifting work in and out of the hard drive. This pretty much sucked as you could go to lunch waiting for the hard drive to do anything.

Memory makers could and did start making memory strips larger than the “legacy limit.” As that became more popular, different manufacturers “solved it” in different ways. Some designed a protocol for “Expanded Memory” and some had a different system for “Extended Memory.” Programmers, of course, got stuck in the middle. I don’t remember which one won.

Apps that don’t “take a breath” like audio (and video) start using memory just like everybody else, but they don’t stop. Several of the Audacity tools need to load the whole performance into memory to work right. This is nothing like calculating a spreadsheet where nobody would know if the app stopped for a split second to shuffle data around. Audio and video run in real time and it’s possible they are the only application using memory at the 8GB limit or however much you have.

I’m in the process of running that test 255 times. 5 successful tests so far…

And now you know why we start it when we go to bed. I don’t expect this to work, but we are covering the bases. Never dismiss a possibility out of hand.

like a glitch in write vs a weak analog connection fizzing out.

Unless you changed it, the timeline only displays audio between maximum volume (0dB) and about -30dB. Anything quieter than that just turns into a straight blue line. There are ways to fix that, but in my opinion, the fix makes day-to-day editing more difficult.

I pull my bouncing sound meters all the way across the screen (grab bar on the left) and change the quiet end from -60dB to -96dB, the limit of 16-bit audio. That’s insanely handy because it lets you look at all sounds likely to be exported at WAV format, whether you can easily hear them or not.

Audacity > Preferences > Interface > Meter Range.


One other idea. There’s two ways to get dropouts. You can get the classic dropout where the system stops paying attention to the work. You get a simple hole in the show.

But there’s another one where the system has to go potty for a second and picks up exactly where it left off when it gets back. Do the two ends of the gap match? If you sucked out the gap in an edit, would the two remaining ends match?

What happens when you reduce the buffer to a very low number?


With all this talk about memory, I’m still not clear what I should be looking for. Could you provide a link to the kind of memory you are talking about?

No, the ends do not match, it is a silent ‘hole’ in the recording. Hence why I need to re-record…that audio data is just absent, I can’t just delete the space and repair that way, otherwise I would.

I just did the ‘amplify’ check on it and ‘New Peak Amplitude’ shows ‘-infinity’, just like your screenshot.

I’ll try a buffer of 1ms for this next rip…

Buffer set to 1ms and no change at all.

I swear I can’t tell that buffer length does anything at all.