download legacy version?

Can someone provide a link to download one of the legacy versions of audacity?


I think they’re contained here:


For Linux we only provide source code. Most Linux distributions provide binaries in their repositories.
Building an old version of Audacity on a modern Linux distribution is likely to be highly problematic due to incompatible library files.

Tarballs for Linux all the way back to version 0.91 are available here:

Which version of Linux are you using, and what do you need a legacy version for?

I did download the standard version for my Ubuntu 15.10 distribution running on a System76 laptop of recent vintage and was trying to discover whether an earlier version would work correctly. It did not.

I then stumbled across Ji M’s site and downloaded the latest version which he provides as a PPA. Same problem, which I describe in this post on Ji’s site (but not yet approved and displayed publicly):

Hi, Ji …

I’m a bit frustrated after recently installing Audacity on a new System76 laptop running Ubuntu and recently upgraded to 15.10.

When I record a voice chunk directly using Audacity, it plays back the recording virtually at light speed. Weird. I’m a casual user, not a sound engineer. I did twiddle the “speed” settings, but that simply slowed down the incoherent recording.

I’ve done the usual “google-it” thing to see if others reported the same problem. I came up with nothing useful. No joy. I downloaded an older version 2. No difference.

Having come across your resources (thank you!), I decided to remove the standard package version and replace it with the latest and greatest version from your PPAs. Surely, I thought, this would fix the problem. It didn’t.

So….have you any idea what may cause such a weird effect? It seems intuitively obvious that a recording made with Audacity should then play it back exactly as it was recorded. Apparently not. I’ve used Audacity for several years with never a problem, so this is a new experience.

Have you any idea what may be wrong? And what I must do to fix this silly problem? I have a project pending and must buy other software if Audacity simply won’t work for me anymore.



Adding to my comment above, if the sound speed is set to 1.0000 (the default) and the “chirp” sound is generated by Audacity, the playback output resembles the rising ugly sound effect used on old radio programs to simulate a creaky door being opened (except higher pitched) and is quite “raw”, to boot.

Definitely NOT a “chirp”!!! > :slight_smile:

The “chirp” generated by Audacity might also be described as something like the sound of a crow being slowly strangled to death. So it isn’t the mike and I frequently use this USB-connected headset to listen to other recordings and chat on Skype. Go figure.

The name “Chirp” does not really describe the effect very well. With the default settings and no track selected, the sound should be a rising tone lasting 30 seconds (not what I would call a “chirp”).

What happens if you import a “known to be good” audio file into Audacity and play it?
What settings do you have in the device toolbar?

Lasts about 2-3 seconds. I agree it sounds not like a “chirp” but like the last mortal moment of a dying crow.

Plays at light speed and sounds like random static. The tracks are original recorded music clips I re-engineered some time ago on Audacity. Until now, they have always played back beautifully.

Whatever is set by default. My original dot-config directory is a virgin.

See You may need to follow that whatever Audacity version you are using.


:laughing: Not quite right then.

I’ve just been reading that PulseAudio has started playing up again on some Ubuntu 15.10 systems, so it could be to do with that.
Do you have just one sound card installed on the machine? If so, you should see an option in both the recording and playback settings of the device toolbar that mentions “hw:0.0”. That setting should allow Audacity to access your sound card hardware directly through ALSA (bypassing Pulse). Ensure that no other audio applications are running and try that option.

The “Panda Jim” PPA version should currently be the best version for your system. Once Ubuntu has the new Audacity 2.1.2 version, then it will probably be worth switching back to the main repository version.

Oh, damn … how embarrassing. You asked:

After posting my reply, I checked those again (found them set to default) and … duh … all is well now they are reset to headphone in/out.

But that raises a question in my mind about why I would have heard anything at all if the sound was not directed to the headphones or received from the mike. If there had been only silence or no playback sound after recording, I’d have quickly figured something needed to be re-configured. And what exactly does “default” mean?

Anyhow, apologies for the bother. I’m a happy camper again. And thanks very much to the development team for Audacity … it’s served me well for some years and I am grateful for it.

“Default” is PulseAudio on systems that use it, as Ubuntu does. You were connected to the same devices, given the system was set to those devices.

PulseAudio sits between the kernel/hardware and Audacity. So it has higher latency than choosing the (hw) device directly.

If you want to use other audio apps while using Audacity you will have to use the workaround at


That is ‘usually’ the case (virtually “always” for consumer level sound cards), though some high level sound cards are able to handle multiple streams without help from Pulse.

Do you know any named examples, in case someone really wants that? I presume we’re talking about hardware mixing?


The RME Hamerfall soundcards have hardware mixing, though I’ve never used one under Linux.
If I remember correctly, the old SoundBlaster AWE (10k1 / 10k2), but these are long obsolete - I’ll dig my old one out when I get time and see if I can get it going :wink: