Disabled effect GUI, can't re-enable. Affecting computer performance.

I am using Windows 7 with Audacity 2.3.3 (the latest one that was developed with Win7 support). I use the plugin Thimeo Perfect Declipper which has a GUI which, for some reason, doesn’t fit properly on my screen. The top part was cut off, yet underneath was a large white area which I couldn’t seem to get rid of.

For some reason I turned off the GUI, but now it takes about 2 minutes to open the effect window and attempting to scroll down causes my computer to crash. I’ve had to cold boot it twice. The worst part is that I uninstalled and reinstalled Audacity, and deleted the Plug-Ins directory, and the problem still persists.

When that non-GUI effects window appears, I cannot find a way to re-enable the GUI. I’ve read something about going into the Preferences menu and toggling something to show GUI for effects, but I don’t see that anywhere.

I want to keep using this plugin, but I can’t find a way to re-enable the GUI, which seems to be the only way it works. I don’t even see an “OK” button to apply the effect. Pressing the enter key brings up what would normally be the “effect in progress” window, where the green bar appears, but nothing appears, just a small gray window which does nothing. The program stops responding a few seconds later. Worst case scenario, task manager doesn’t start and I have to hard boot the computer.

Is there something I can do to re-enable the GUI without actually opening the effect? Perhaps some text document in my computer’s AppData folder I can change a 0 to a 1? I’ve been doing a lot of work with this plugin and I’d really like to be able to use it again. Thanks in advance!

Following up on this - I’ve found and opened the “pluginsettings.cfg” in the AppData folder using Notepad, but a cursory glance with Ctrl+F doesn’t bring up any results for effect names. I’m also hesitant to do trial-and-error in this file, as trial-and-error is what put me in this position to begin with.

Very wise. “pluginregistry.cfg” and “pluginsettings.cfg” are NOT intended for humans. They are intended only for internal use by Audacity.

Something that you can try is (with Audacity closed) to copy pluginsettings.cfg to another location (as a backup), and then delete the original version.
This will reset all effects and plug-ins back to their default settings. A new “pluginsettings.cfg” file will be created automatically when you launch Audacity.
This may be a bit drastic (it resets ALL effects and plug-ins), but it may be a useful “Get Out Of Jail Free” card.

Thank you. I’ll give this a shot.

While digging around in that file, I did find, at the VERY bottom (the very last line of the file), something to the effect of “DisplayGUI=0”. This plugin was the last/most recent I’ve installed and modified*. While I don’t want to risk it, I think this could potentially be what I posited in my first post. But I don’t want to risk it.

*I’ve only installed three external plugins, and one of them was the Hard Limiter that came with older Audacity builds (I prefer it to the current Limiter). With only two other plugins installed, perhaps comparing it to the newly-generated one would shed some light on whether that “0” I found is what I’m looking for or not.

That’s probably it, but easier / safer to just reset the whole lot if you don’t mind resetting all of the effects.
Let us know how you get on.

It probably wasn’t the smartest move, but I tried changing the settings file directly. It seemed like a low enough risk because I recognized a line above it, which said “BufferSize=8192”, as being specific to that particular plugin, and the line “UseGUI=0” two lines under it (with only a blank line underneath it, it was the last line of the document) indicated that this was a fairly safe bet. I changed the 0 to 1 and, thankfully, it worked. That was the only character I changed in the entire document.

Having lost an entire computer by using the Registry Editor (even though I followed the instructions perfectly), I know better than to mess with these kinds of files. But this seemed like a low-risk move, and I surmised (possibly incorrectly) that if it went wrong, I could delete the settings file and generate a new one. Fortunately, my guess was right, and I haven’t run into any problems.

I can’t post images since this is a new forum account, so I can’t show the incorrect size of the GUI. However, considering the alternative is having my computer crash, I’ll learn to live with the top 10% of the window not fitting on the screen. A small price to pay.

Thank you, Steve, for your advice - even though I disregarded it, it WAS still very helpful. Cheers!

Thanks for the update InStepWithTheStars. I guessed that you might have a go once you knew that. Yes you surmised correctly.
Glad that you fixed the problem :slight_smile:

Thank you again for that follow-up! I have no intention of mucking around in that file, but I appreciate the confirmation that I can delete the flawed file and generate a new one without a catastrophic meltdown. That wasn’t the case with my old computer, but that thing was terrible anyway. :smiley: Anyway, thanks again!