Digital Keyboard Sustain (including sustain pedal) is not recording in Audacity

I can’t get any sustain on my digital piano keyboard to last beyond about 1 second when I record using audacity. The sustain duration is the same whether I manually hold down a note or use the keyboard’s sustain pedal to hold down the note. This happens both when I use a keyboard as the mike input into the computer jack or when I try to record to audacity using my computer’s realtec mike. This was not a problem when I was using Windows 10 on my HP DV6 with Audacity 2.1.1. But that computer was failing and I had to get a different computer and install Audacity on this new computer.

Digital Piano Keyboard – Yamaha P70

Sustain pedal – Gear

Piano is connected to Computer from piano keyboard’s headphone line out

Computer – new HP 17.3 laptop with a combo jack

Piano connects from its headphone jack (1/8 inch stereo line out) to a Y-splitter mike-in (not the headphone-out) in the computer combo jack (“3.5 jack cable adapter converter for laptop with headphone/microphone simultaneously” ordered through Amazon) which now allows me to record the music sound OK.

Operating system – Windows 10

Audacity version – 2.4.1

I’ve tested whether a piano sustain sound works through my computer over an internet line from another piano, and it does. The Y-splitter appears to work OK and the problem exists with audacity even using the realtec mike in the computer. So I don’t think it’s a computer problem. It appears to be an audacity issue.

Can anyone help me understand what I need to do to be able to record music with sustained notes to this new version of audacity? Thank you!

Either you didn’t turn off the Windows Enhancements, or you have one of the Chat/Zoom/Skype programs running in the background. They all hate music.

Make sure Audacity is the only thing running when you use it.


Thank you for responding. I tried to disable the sound enhancements for both mike inputs, got out of audacity and back in and nothing changed. No teleconferencing programs are on. I even disconnected from the internet and turned off my security and virus protection. None of that helped. I appreciate any help as I am out of ideas for what might fix this.

Did you succeed? Were there Windows sound enhancements enabled and were you able to turn them off?

Yes, the sound enhancements were enabled. I disabled the Windows sound enhancements for both the mike going into the combo jack and for the realtec mike. I reastarted audacity. Disabling the Window enhancements did not fix the problem. The sustain lasts for about 1 second on any audacity 2.4.1 recording, far shorter than what is actually sustaining on my keyboard.

It’s possible the problem is something else, but this is the poster child for Automatic Noise Reduction.

This is how it works: Listen to the show and any single sound that’s there for longer than a set amount of time has to be noise and get rid of it. Speech has no sustained sound and so this is normally a safe bet. That kills music and most singing, but it’s a gift from the angels if you’re trying to have a conference in a noisy environment. Most Skype/Zoom wouldn’t work without this. Picture 6 people in your conference all with air conditioning noise.

That effect can hide in many different places. Windows and Zoom setup are the low-hanging fruit. You can get a mixer and certain microphones with auto noise reduction built-in. All phones can do this.

Are you trying to record on your phone? iPhones have two different recorders: Voice Memo which has the effect and Music Memo which doesn’t.

Auto Noise Reduction is ubiquitous and it’s all over the place.


I think it’s working!!! ’

This morning, I disabled ALL the Windows sound enhancements for ALL speakers and mikes. Then I completely shutdown the computer and brought it back up. The pedal appears to be sustaining in audacity now. There’s quite a bit of white noise in the background, but I think that’s cabling and can work on that for awhile with the cable connections before asking for help. Thank you Koz and Steve for being SO responsive and for suggesting the sound enhancements fix. I just needed to do it right!


There’s quite a bit of white noise in the background

Correct. Because you also turned off Noise Reduction. If it is plain rain-in-the-trees noise (shshshshsh) you can use Audacity Noise Reduction to suppress it.