digital break up every 15 seconds

I’m using a Lindy USB “Audio grabber” a/d converter and recording with Audacity on a Macbook Pro running 10.9.3 Maverick. I get 5 seconds corruption at the start of every recording then every 15 seconds the audio becomes corrupted for a couple of seconds then records ok again. The Lindy records fine onto Garage Band but its a mighty clumsy way of getting voice overs on to the FCP timeline. I’ve tried a variety of sources and just about every sampling rate / buffer setting available but no improvement. Anyone got any ideas…please?

counterintuitively shortening the buffer can be the cure …

Which Audacity?

My MBP is a 15".

What else is running?
Go > Utilities > Activity Monitor.

View %CPU and see where your action is. Do a couple of obvious things like restart without your network connected. Close BlueTooth and WiFi.

Can you make it worse? That may sound like a dunderheaded thing to do, but if you can change it at all, either direction that may give us a clue.

Are you recording at a nose-bleed high data rate, or plain 44100, 16-bit, stereo?

Are you going through a USB hub? Don’t do that.

Did you actually install Audacity by dragging the Audacity program folder into /Applications? You can get some very serious magic if you don’t install right.


What’s the size of that hard drive and how much is left? Are you using an external USB drive?


Thanks for so many ideas! I have since discovered that the corruption happens on importing to Garage Band too, but a little less obvious.
On Audacity, the only parameter which makes any difference is changing the sample rate: at 48k there is a warbling / repeating effect for 5 seconds and sampling at 8k it is more of a fizzing effect which lasts for half a second. I’ve tried the extremes on the Buffer, latency correction (+and- values), Tried sample rate converter, real time and HQ, low Q to Hi Q. Played around with dither settings.
Tried killing bluetooth, wifi etc. MBP has a 2.5Ghz intel processor with 8Gb ram and almost 450Gb space on the drive. Audacity is definitely in the Apps folder, it’s not really possible to dump all my apps on to a separate HD. Dunno, maybe I need to bang on Lindy’s door.

I have now tried the Lindy a/d converter with a MacPro OS x 10.9.5 with Audacity 2.0.6 - same warbling / repeating effect every 15 seconds . Lindy technical help are mystified and suggest I return the unit. As no one else has experienced this problem I guess I must have a faulty Lindy?

If you can change computers and the problem follows you, then chances are high the unit is bad.