Did I just waste money on a VST Plugin ?

Darn did I just waste $30 on a WAVES VST Plugin ?

My Computer says it’s a X86 , Now the plug I bought is x64 , I’m reading audacity only takes x32 ?

the plug in is apparently installed on my laptop , so what the heck does x86 mean ?

“X86” =32-bit.

There’s usually the option to try-before-you-buy with plug-ins,
to check they work for you before parting with money.

If your Windows computer has a 64-bit Operating System it can run both 32-bit and 64-bit software.
But a 64-bit version of Audacity is not yet available for Windows.
Its competitor OCENaudio has 64-bit version which may be able to run your 64-bit waves plugin,
but only if you have a 64-bit Windows Operating System.

AH I just did Factory Reset of my LAPTOP ,

My Roaming App Folder isn’t working right ,

I think all WAVES plugins come with both 64 AND 32 Version , somehow its not choosing the 32 ,

my other waves were just fine.

I figure this has to be the case , Otherwise it would of never installed on my LAPTOP Correct ?

Ouch, that’s a drastic measure.

The recent versions of their plugins are only available in 64-bit, see …

If you have a 64-bit Windows Operating System, 64-bit plugins can be installed, but 32-bit Audacity won’t see them.
64-bit Audio editors, (like OCENaudio), may be able to see & use 64-bit plug-ins.
In the waves plugin tech-specs there is a list of the software they are known to work with,
https ://www.waves.com/support/tech-specs/supported-hosts , (Audacity is not mentioned).

Argh yes because when I installed my other 2 apps it was before the update with WAVES 11.

Also the last time this also all worked was with installing with Audacity it was during like August 2018 or 2019 ?

has their also been a new audacity release since then too ?

is their a audacity from 2018 ava ?

I posted this Help topic back in April 2018 , the method that worked is not this time around ,

Was AUDACITY a different build in 2018?


Don’t tell me WAVES just made a big enough change to my stuff headed to the trash can :laughing:

OK Good News I can roll back to WAVES 10 , I did spot a GREGG WELLS X32 dll in the list of FAILED Plugs In in the disabled list in AUDACITY

I tried installing , I must be doing something wrong of course ,

Oh yeah that’s another thing how do I refresh the list ?

all the stuff is no longer installed but yet some how all the stuff is showing on the disable list.
I even uninstalled audacity and it showed up
still on the disabled list , very weird.

By the way I just installed AUDACITY 2.2.2

that’s the one I had right before I factory reset my pc , Imagine it’s the same one I was referring to in the help topic I referred to.

Unfortunately there’s not yet any automated way to do that. It has to be done by manually removing the two configuration files:

  • pluginregistry.cfg
  • pluginsettings.cfg

You will find those files in the hidden folder:

(“” is your computer log-in name)
Ensure that you shut down Audacity before deleting those files.


looks like I am going to be fine ,

I seriously just threw everything in the AUDACITY Plugins In Folder ,

It eventfully connected itself to what it needed LOL.

MADNESS Works ! :laughing:

Thanks Everyone ! :mrgreen: