Deleting the preferences file for audacity on the mac

Good day. I am running the latest version of audacity and when I play files now they sound glitchy like there are either buffering problems or something. I deleted audacity by putting it in the trash, emptied the trash and from the DMG file copied it back in to the applications folder. I still get the glutting no matter what type of file I play. I am thinking that the setting or cfg file got corrupted but can’t find it to delete it. I’ve looked in the library folder and don’t see anything related to audacity in the preferences folder or the library folder. I’d rather not have to reformat the mac. Interestingly if I mix something and play the mix using another app the glutting doesn’t carry over. It must have something to do with playback. I’m using a matchbook air with 512 gb ssd drive and 8gb ram. One other thing. This didn’t seem to happen until I move a rather large bunch of files. All other audio apps play fine which is why I believe it has something to do with the preferences file. Thanks.

Please see this post . Let us know the answers to those questions in your case and see if any suggestions in that topic help the problem.

Since we don’t know the exact three-section version number of Audacity that you have, I also suggest you try the 2.0.5 release candidate here: .

I doubt preferences reset will help unless you are using very unusual sample rates in Audacity, but first of all, Audacity > Quit Audacity. To find audacity.cfg, open Finder, Go > Go to Folder and type:

~/Library/Application Support/audacity/

then delete audacity.cfg.

If you have (or have ever had) 1.2 on your system, you will also have to go to:


and delete the file called “audacity Preferences”.

You could also use Go > Utilities > Disk Utility and run “Verify Disk”.


Gale, thanks for the info. It’s applications support that I missed. I’ll definitely try the 2.5 beta. I’ve actually never seen the problem I am having and thought it might be something on my computer since it seemed to develop when I moved my projects in to one folder. it was about 250 MB of audio. Since all other audio apps seem to play files well My thought it’s audacity since this also happens when just playing any file in the program. I havn’t changed any sampling rates at all. The mac accessibility is extraordinary and working extremely well. Have a great day.

@johnythehess: the 2.5 is not a beta, but a “release candidate” version that would be officially released as version 2.5 if it passes testing. In this case there will be a second release candidate but you can get whichever is the current release candidate when you visit .

Let us know if the playback problem is fixed when you reset preferences. If not, the problem is a mystery because none of our Macs show this problem. But you can read as I suggested if the problem persists.


Gale, sorry for the beta reference. I did download the first RC of 2.5 and this did not fix the problem although I was happy to have open with back from finder. I also did try going back to an older version and the problem still persists. I did look at the topic you referenced and those suggestions also did nothing. Now, pardon my ignorants here or my inability to follow instructions but I still can’t find the preffferences file. I went to ~/library/applications support and see nothing at all for audacity. When I look at ~/library/ preferences or preference panes nothing is there. Is something hidden or have I totally misunderstood the path? Please straighten me out on this. I do want to delete them and start over because if this problem persists I may resort to reformatting the machine. It’s very possible something got corrupted when I moved files. This shouldn’t happen but This is the first SSD drive I’ve worked with and wonder if things can happen like this. Thanks so much for your help and have a great day.

This is the first SSD drive I’ve worked with and wonder if things can happen like this.

No. The only thing you notice with an SSD is the machine becomes scary fast and doesn’t get hot, perfect for live video or audio.

Yours might be broken or installed poorly, but it’s highly unlikely.

I have SSDs in my last two MacBook Pros and I would never go back to spinning rust.

You only get entries in /User/koz/Library/Application Support/audacity after you install and run Audacity.

In Macs you can start over by trashing the dock icon, /Applications/Audacity and /Users/koz/Library/Application Support/audacity (note the lower case “a”).

That’s it. Restart the machine and if you did a plain install, Audacity will no longer be around.

You can tell if you got a fresh start because all your preferences will be missing and you’ll get the New User welcome screen.

Some of the newer OS-X installs restrict access to the Library folders.


There is a way you can louse that up. I have a high level folder called “Installers-Keys-Settings.” In it are several Audacity versions and other notes, images and files. One re-install, the OS struggled to find the program and ended up opening one of those instead of the real program.

It did take me a while…


Oh. You’re on a MacBook Air. Or as we call it, a notoriously slow and underpowered MacBook Air. I think they always came with SSDs didn’t they? They had to. Did you change to a larger one? Are you sure the internal power system is up to it? Quite a few corners were cut to make that machine small and light.

It worked. People took one look at the concrete-lined MacBook Pros and streaked straight to the Air. But few of them are doing heavy production. They use them as powerful tablets and very powerful iPhones.

There’s another thing you can try. Can you make it worse? If you run some processor-heavy applications and then try to play Audacity, too, does it go face-first into the mud?

You can try Audacity 2.0.3, the stable version before the 2.0.4 rollout.


Can you do the select all and copy for the two folder paths here:

If you paste each one in turn, it will ensure Go > Go to Folder looks in the correct place.

Lion and Mountain Lion hide your user Library but they will show it to you if you use Go > Go to Folder.


Koz and Gale, you’ve given me much to explore and work with. Gale thanks for the link to the folder paths. I’ll try this. Koz, actually, This machine is not under powered at all. I did get the max specks and it has proven to work excellently with Audacity. I agree about the speed. I am working with approximately 30 to 35 tracks and the machine doesn’t Blink. Running other apps doesn’t seem to overload it at all so I am confident that this machine is doing it’s job. I’ll try these suggestions and thanks you both for the great detail. have a great day.

The problem is solved. Following the instructions left by Koz and Gale I was able to delete the preferences file. The crackling is gone and playback is as clean as ever. Thanks guys for all the help and hanging with me on this one.