Default metadata tags when exporting aren't saving between sessions

Hi all,

Before explaining the issue here’s the details of what I’m using:
Audacity 2.3.2
MacOS Mojave 10.14.6

I’ve been using Audacity for a few years to export .mp4 audio and turn into .mp3. I recently updated to 2.3.2 and the issue I’m now having is that when exporting the default metadata tags are getting reset every time I export a new file.
In previous versions I was able to set a default and then whenever I would export a new file the certain tags (for me was artist,album,genre & year) would be pre filled with the default I wanted.
Now with 2.3.2 I have to either enter them manually each time or load the .xml file I saved with the tags.

Just wondering if this is a new way Audacity is meant to run or if this is a bug?

Thanks all

If you import a file that has metadata into an Audacity project, the file’s metadata overwrites Audacity’s default metadata. This is an intended feature and has been so for a very long time.

It is intended to add a Macro command for specifying metadata. When implemented, this will allow users to set up one or more “default” sets of metadata that may be linked to keyboard shortcuts.

The files I’m importing have no metadata, same files I used to with the old version. Is there just no way to set a default metadata tags to auto load when exporting any files like before?

If they have no metadata, then they should not change the project’s metadata. I cannot reproduce this issue.

When was “before”? There have been no changes to Metadata handling for a long time.

Before was a previous version, I’m not sure which one exactly I had before updating to 2.3.2.
But the issue is in the current version you can’t set a default template with metadata. It does not work. There a ‘Template’ section (load, save, set default) when editing Metadata for exported files.
For example in previous version if you put ‘Artist Name’ - ‘MyArtistOne’ and selected set default under Template. Next time you exported a file with no previous data, ‘MyArtistOne’ would already be filled out in the Artist Name.
In the current version of 2.3.2 this does not work. The defaults are not saved even when a file has 0 metadata.

Try to import a mp3, then export and clear all meta data and save as. Now next time you load that file and try exporting, it should have no meta data. Now try setting a default in template and close audacity. Now reopen and try exporting that new file that have stripped meta data…the default you set should already be there since there’s no tags on this new file yet it’s still all blank…that’s the issue that wasn’t happening in the previous version of Audacity

  1. “Edit menu > Metadata”
  2. “Load” or manually enter the required metadata
  3. Click the “Set default” button
  4. Click the “OK” button.

To check that the default has been correctly set:
5) “File menu > New”
6) In the new project’s menu: “Edit menu > Metadata”

To close the Metadata Editor without saving, click the “Cancel” button.