DDJ400 Sample Rate Error 9997

Hello all,

I finally made an account to post my own thread because after searching possibly every website, forum thread, reddit thread, youtube video, and more in the entire world I am still completely unable to solve the Invalid Sample Rate Error -9997 issue with my DDJ-400.

To summarize: I had been using Audacity paired with Rekordbox to record DJ mixes through my DDJ-400 via a bluetooth connection to my speakers. Now you may know Bluetooth will cause delays in the audio so I have moved to an RCA to 3.5mm wire to my speakers however this is where the Sample Rate Error 9997 comes in. I have checked the sample rate everywhere in my laptop’s audio settings, everything has been matched to both 44100 and 48000hz. I have tried recording in stereo and mono channels. I have tried reinstalling and uninstalling everything from Audacity to Rekordbox to my laptop’s audio drivers. I’ve tried using MME instead of WASAPI (which Rekordbox doesn’t really like).

Set-Up is:
Host: Windows WASAPI
Playback Device: Line (DDJ-400)
Recording Device: Line (DDJ-400 loopback)
Recording Channels: Stereo

Also, before anyone asks yes I must use Audacity to record my mixes, not internally in Rekordbox because I am using some streaming audio sources.

Please… somebody… anybody… end this sample rate nightmare I am stuck in.

1 Like

I don’t have the answer to this either, but if you have searched the threads, you will find many reports of people not getting Audacity and RecordBox to work together.

and other issues, so this is a generally a good idea.

So which is it? 44100 or 48000?

and I imagine the occasional reboot…

This looks like a recipe for disaster. Just sayin’

Not sure what you meant by the loopback and all of that sounding like a disaster… because it worked every single time before on the Bluetooth connection but I guess thank you for your input… Clearly there is no solution to this issue. Wherefore art thou, Audacity gods? Have mercy on me. :laughing:

Not sure what you meant by the loopback and all of that sounding like a disaster… because it worked every single time before

Using loopback with the same input input & output device creates a feedback loop. You can get an echo and if there is overall gain it will increase out of control similar to acoustic feedback with a mic in front of a speaker.

Normally, loopback is used for streaming audio where there is no connection to the soundcard’s (or other devices’) hardware input.

I see… Interesting because that’s pretty much how it was always set for my previous recording with the Bluetooth set-up and never had an issue.

I guess I will just have to figure out another way… I’ve tried OBS and OcenAudio to no avail as well.