Data files lost after merge and rename

Windows 10, Audacity 2.1.0

In searching around after this error occurred, I’ve learned that renaming audacity projects outside of the program is a terrible, awful, horrible thing, which I obviously did not know, but all the suggested fixes seem to involve changing the project name back. However, this seems to be a special case because not only did audacity not create a new data file for the new project name, the old project data files appear to have disappeared completely. They’re nowhere to be found on the thumb drive I was working from, and I couldn’t locate them by searching the PC’s directories either.

I don’t know what exactly caused the issue, so I’m going to try to describe what I did leading up to it. Briefly, I’m editing a podcast that was recorded in two parts, with separate tracks for both participants. I had finished editing both, and I copied and pasted the tracks from part 2 at the end of part 1, deleted a tiny bit of one track to account for the slight difference in when the first 2 tracks stopped recording, and merged them. I saved the project and closed out out of audacity. Then (kicking myself for this now) I renamed the project to reflect that it now contained the full episode, not just part 1. When I tried to open it again a minute later, I got an error message saying "Couldn’t find the project data folder: “Full Pilot Episode Edited_data”. After a minute of furious searching, I realized that renaming might have been the problem, so I changed it back to Pilot Episode Part 1 (manually renamed rather than “Undo Rename”, if it matters). No dice; the old project files are nowhere to be found and there is no data file matching the new name.

Anyone have any idea what might have happened and how I can fix this? Thanks in advance for your help.

OK, so here is something to try:

  1. Before you do anything else, read the first 15 or so lines (up to the light blue box) from this link: Managing Audacity Projects - Audacity Manual

  2. Read it again.

  3. So we’re looking for two major things: 1 - a file named “xyz.aup” AND a folder named “xyz_data” (with no dot anything), where “xyz” is the name of your project.

  4. Open up File Manager and see if you can’t locate the directory where you think the file and the folder reside. Before you start looking at the contents of this directory do the following; Click on the “View” tab. Under that, click “Details”. To the right of that, you will see three checkboxes. Make sure “File Name Extensions” is checked.

  5. Now see if you can’t locate the .aup file and the directory. If you do, it is possible that you have misspelled one of the file names. See if you can’t figure out the problem and correct it.

  6. If you don’t see your file and directory together, you can enter “.aup" in File Manager’s search directory to search for the control file and ".au” to search for both .aup control files and the individual .au data files. If you find .au files, do NOT move them!

I hope this helps. :smiley:

Thanks for the suggestion! As it turns out I was able to find it before I saw your post, but I really appreciate you taking the time to reply. I will definitely remember to check for hidden file extensions if I run into a problem like this in the future!

:smiley: You are welcome. :smiley:

In the next release of Audacity version 3.0.0, everything will be merged into one single file so we should not longer have this difficulty. :smiley: