Dansrue cassette->mp3 device error -9986 / crashing

Hello, I bought a Dansrue cassette player which converts to mp3. Following the instructions, and reading other posts on this forum, I think I have it set up correctly. In the System Settings Sound Preferences, I have the USB PnP Audio Device selected as the Input. When I play the cassette, the meter bars show that it is playing correctly, at least in System Preferences.

In Audacity (2.3.0), I have the USB Pnp Audio Device selected as the Recording Device. However, when I press Record, I get this error:
“Error opening recording device. Error code: -9986 Internal PortAudio error”

Interestingly, when I restarted Audacity and tried again, it worked. I was able to record one whole song off the tape. Then, about 15 seconds into the second song, Audacity crashed. Now, I am getting that error again. I can’t get it to work after several tries.

Any idea how I can get this working?

EDIT: Just now it worked again. And crashed again. I noticed this time, that the player disappears from the Input devices in System Preferences when this happens. The connection seems flaky, I think that is what is causing the problem. Not sure how to fix it though or why it would be dropping connection like that.

Do you have another USB cable you can try? Are you plugging the cable directly into the Mac (not through a hub). Does the device disappear from System Preferences?

– Bill

It does disappear from System Preferences. I am using the cable that came with the device, and it is going through a hub. I’ll try directly connecting and see if that works…

no - directly connecting has the same problem. I don’t have another cable of this type.

Honestly this thing is kind of crappy. I am going to return it, buy a better walkman, and just record using line-in. It will probably be better quality anyway.

No kidding. We’ve had several posts lately of users having the exact same issue with this device. It appears to be sold under several different names.

Does your Mac have a line in? It’s hard to find a decent cassette deck these days. A cheap boombox might be a better choice than a “walkman”. Just make sure it has a line out.

– Bill

Yes, there have been loads of them :frowning:. Here’s another one from just a few hours ago: appears to be recording but no sound - #5 by clsmith15

I am running Audacity 2.3.0 on a Mac running OS 13.6. I have recorded nearly 45000 songs into iTunes using Audacity. Today, about 3/4 of the way through a cassette, it stopped recording. Deck was running but the Audacity plot was stopped. I got the “Error opening recording device. Error code -9986 PortAudio error.” upon re-starting Audacity. What gives ?

PortAudio is the software library that Audacity uses to communicate with the computer sound system.

Error code “-9986” will occur if PortAudio cannot find the audio device. This would suggest that the device has become disconnected from the computer.

Check that the USB lead and plugs are secure, then check in the Windows Sound Control Panel to see if the USB device is currently connected and enabled.

If the device is enabled in the Windows Sound Control Panel, select “Rescan Audio Devices” in Audacity’s Transport menu, Then check and reset if necessary, the settings in the device toolbar.

If the device is not enabled, check the USB lead and connectors more thoroughly, and reboot the computer. Is the device enabled in the Windows Sound Control Panel now? If not, the device, or USB lead, have probably died.

  1. Try a new USB lead if possible.
  2. Try a different USB socket on the computer if possible.
  3. Try a different computer if possible.
  4. Try a different USB cassette player if possible.