Dangit! Running ACX check ruins my Noise Floor!

I’ve been relying on GarageBand for… some years now… until just recently trying to branch into audiobooks with ACX. I recorded my first 15 minutes, submitted for approval, got approved, but saw I failed the ACX submission requirements. Been doing a lot of research this past week trying to figure out how to troubleshoot, found audacity and the handy ACX check tool, even found some nice tutorials for setting up a chain (now called macro) to apply all of the mastering tools in one swoop and now my “ACX” macro, per https://wiki.audacityteam.org/wiki/Audiobook_Mastering, includes all of this:

Effect > Filter curve… > Manage > Factory Presets > : Low roll-off for speech > OK.
Effect > RMS Normalize: Target RMS Level -20dB > OK.
Effect > Limiter: Soft Limit, 0.00, 0.00, -3.50dB, 10.00, No > OK.
Analyze > ACX-Check.

I can tell it’s working but every time, my noise floor is too high after applying these tools. (Right now it’s ending up around -55.7dB after applying the macro)

Screen Shot 2020-05-08 at 3.39.10 PM.jpg
To be clear, I am not uploading the audio from my previous recording in GarageBand into Audacity, as I’m assuming I’ll just need to re-record all of that once I find settings and tools that will work. So the clip of audio in the screenshot is just a test recording (one of maybe a hundred I’ve tried over the past few days ugh) I’ve read in some forum posts here that the problem is usually with original recording so I’ve tried turning my microphone’s input settings all over the place and nothing fixes my final outcome.

I’m recording in a vocal booth I constructed out of PVC and double layered moving blankets, which closely resembles a https://www.bookablevo.com/tri-booth although mine goes all the way to the floor and there are more blankets, so the space is very dead sound-wise.

I’m using a Blue Spark Microphone, through a Steinberg UR-22 audio interface, to a MacBook pro running Mac Os Catalina 10.15.3 and Audacity version 2.3.3

Note I am aware (I believe) Audacity isn’t currently supported on anything beyond Mac OS X because of a restriction on permissions to microphones, but I found a workaround (I think on these forums) to type in a line of code into terminal, and keep that open to utilize audacity with this set up, and that has worked well.

Hoping there’s a setting I’m missing here and all of the work I’ve done building this setup has not been in vain. I feel like I’m so close! Thank you in advance for any suggestions!

(now called macro)

Do you remember where you got the Macro from?

If you’re still set up, can you record a sound test? We can’t tell enough from a finished and mastered failure to know what’s happening.


Other than cutting it to length, Do Not Touch Anything. No effects, filters or corrections. Read down the blue links. They’re very short. Export the WAV and post it to the forum.


I put the macro together myself just adding each tool that is recommended with the corresponding settings.

Screen Shot 2020-05-08 at 5.18.49 PM.jpg
Here’s the sound test. One take reading this for the first time – no judgment haha!

Thank you for all that. Prizes awarded if you can make it through the whole sentence without taking a breath .

This one’s a puzzler. I can’t find anything broken…but it doesn’t work.

Yes, there’s too much noise in the presentation, but there’s nothing special about the noise. It’s plain, ordinary, straight-off-the-shelf, pink noise. (gentle rain in the trees—shshshshsh) The kind of noise all electronics makes.

But it should not be doing that. It’s a respectable microphone plugged into a respectable preamp. Anything magic about them? You got a “really good deal” on eBay because someone was upgrading to another microphone?

The Steinberg has the option of two different power systems on the back. Which one do you use?

Are you plugged into #1? Where is INPUT 1 GAIN set? Where is INPUT 2 GAIN set? Are you capturing in Stereo and deleting the blank right-hand channel?


You should be speaking roughly into the BLUE company name. It’s a side-fire microphone. The two switches should be flat (no bend) and 0 (not -20dB).

Anything there?

The studio worked. I don’t hear anything but the electronics hiss. No dogs, clocks, or refrigerators. Voice quality is perfect.


Can you post a text file of the whole macro?


Good morning Koz! So, nothing magic about the mic/preamp - bought both new Guitar Center a few years ago.

Plugged into Mic 1, INPUT 1 GAIN was set pretty high on that test recording because everything I’ve seen says to sound check so occasional peaks are around -6 dB. Although compared to all my previous recordings in other programs, that’s pretty high. Then again, when I’ve kept the input lower, around maybe 60%, after mastering, maybe I’ve imagined it but the “pink” noise seemed to be worse. Attaching a couple test recordings at different input levels here.

Audacity setting says I’m capturing in Mono.
Screen Shot 2020-05-09 at 10.05.22 AM.jpg


Shot of preamp (Hi-Z button pressed in)
ACX.txt (370 Bytes)
Here’s a shot of my mic and pop filter roughly 7 inches distance, speaking into the blue company name side. I’m actually not sure what you are describing by “The two switches should be flat (no bend) and 0 (not -20dB).”
Text file of “ACX” macro attached as well.

Screen Shot 2020-05-09 at 13.35.45.png
I need to come back later.


I was really hoping you had your -20 dB switch in the wrong position. That would have been such an easy fix. It satisfies all the symptoms. 20 dB higher noise than normal, pink noise type, perfect voice, etc.

That switch is used when you want to perform a massively loud instrument (trumpet, bugle, trombone) into the microphone. It reduces the sensitivity of the microphone so it doesn’t misbehave, overload, or distort. Many microphones can do that.

If you try to speak into the microphone with that switch on, it will seem that the noise is 20dB too loud. -55 dB instead of -75 dB which is would be normal. It’s so perfect you should go into your instructions and see if there is a way to set that switch even though there isn’t a physical switch.

Is there a special driver app or communications software package?


Shoot a normal, short, voice microphone test. Stop. Shoot the same voice with the microphone backwards. Speak into the rear of the round grill on top with the BLUE name away from you. Try not to change the studio very much when you do this, and don’t change any settings. Just flip the mic around. It’s a volume test, so you don’t need the pop and blast filter.

Slate the sound: “This is the Spark from the front…this is the Spark from the front.”

“This is the Spark from the back…this is the Spark from the back.”


I know it doesn’t make any difference whether the microphone is upside down or not, but the instructions are clear this is a directional microphone and the different between front and back volume is expected to be (wait for it) about 20dB.

I can’t wait to see if your voice volume drops by 20dB when you speak into the back.


Sorry for the delay Koz. (mother’s day stuff)

Here are those test recording(s)!

My model Blue Spark doesn’t have those switches for some reason, but it does have this “focus control” button on the back which has been pressed in.
The only other switch type thing like this is the one on the preamp I mentioned – the high-z button, but it looks like that effects input 2, which I’m not using as far as I can tell.

My model Blue Spark doesn’t have those switches for some reason

The newer model Spark SL has the switches.

Your Focus Control is a low-pitch rumble filter when pushed in. It was taken over by the newer straight-line/bent-line switch. Neither makes any difference because step one in Audacity Audiobook Mastering is a low pitch rumble filter. Many home microphones won’t pass ACX without that filter in mastering.

We’re getting really close to Stump The Band time.

The Hi-Z switch only affects connection #2. The Spark is a Low-Z microphone and connection #1 is good.

The Front/Back thing appears correct. ‘Back’ is muffled, dull, and low volume. Perfectly normal.

I see you’re using the vibration/shock mount to hold up the Spark. Typically those are like rubber bands and if you very gently tap the microphone it should sloppy wiggle at you. The cable on the rear should have a little dip in it so the cable is not tight. I call it the Drip Loop.

Screen Shot 2020-05-10 at 18.35.19.png
I can think of two more possibilities.

High ambient noise is a remote possibility but we can test for that. Make up a heavy towel roll or tunnel that will fit over the microphone. It’s best if the toweling doesn’t touch. Do a normal voice with a second or two background sounds then slide the sound cave over the microphone. Try to hold it steady for a second or two. Stop. You’re creating a second sound studio inside your existing larger studio. We’re listening for a change of background noise.

Put the towel away.

Last is a desperation method recording. Take off the pop and blast filter (tennis racket). Move the microphone so it’s between your nose and ear instead of straight ahead. Position B. And a lot closer. Say one power fist instead of a full Hawaiian Shaka.

You will almost certainly need to turn the Steinberg down. That’s actually the goal. Occasional blue wave tips at 50%. Mostly below that. Announce a ten second test.


Happy Monday Koz,

I’ve flipped my mic back right side up and ensured there is ample drip loop in the cable plugged into the mic.

I then recorded the towel test, holding a double folded thick towel over the mic:

And next the desperation mode recording, first with input gain at 75% and then stopped recording, and followed by turning the input gain all the way down.

Nervous to hear we’re almost stumping the band but thank you for continuing to investigate!

sharcmerman towel test.wav

I don’t understand any of this. When you put the noise-shielding, protective towel on, the noise level went up…*

However, I did get one to work.

I started with the 75% reading, applied normal Audiobook Mastering followed by Noise Reduction of the Beast (6, 6, 6).
It sounds natural and it easily passes ACX conformance.

Practical Noise should be quieter than -65dB.

Screen Shot 2020-05-11 at 10.17.20.png

Drag-select some of the clean background noise. Effect > Noise Reduction > Get Noise Profile. Select the whole track > Effect > Noise Reduction: 6, 6, 6, Reduce > OK.

That may be the way of the future.


Wow. Ok I’ll do some more desperation mode around 75% and see if that continues to pass inspection.

If this works for ACX, that works for me, but because of the nature of some of my other voice work, desperation mode would restrict some other performances. I only worry that the other work I refer to - commercials, characters, etc - might have lower quality than I was aware of before going through this ACX process. In your opinion, should I look into trying out an alternative mic or preamp? And do you have opinions on options for those? I see different people’s recommendations all over the internet, but have valued your feedback here.

the other work I refer to - commercials, characters, etc

The stress is on ACX Compliance because in general, if you can make it past them, you can do anything else. For example, their specifications are a close cousin to Broadcast Proof of Performance, the quality check your (US) station has to pass before you go on the air.

should I look into trying out an alternative mic or preamp?

There is one easy way out. Get yourself rolling at a commercial sound studio while you’re working on your home microphones. Several posters have done that. The only downside is keeping all your book chapters matching. Don’t bring a home microphone on-line half-way through a book.

Also regard Ian in Hollywood (the real place not the Dream Factory). He holds the record for the longest forum posting. 39 forum chapters and over a year. All he wanted was read for audiobooks from his apartment just off La Brea. We did get him working and he’s a successful performer.

I have no recommendations other than what you have can be made to work. I can usually guess at it, but in your case you have enough conflicting symptoms and conditions that I’m going to step quietly back and watch. Did you offend a sorcerer recently?

One note. If you do opt for another rig, read the complaints, not the recommendations.


Hello again Koz!

I have been meaning to follow up and thank you again for all of your guidance, but I kept wanting to finish this audiobook submission before giving the all clear.

Today I’ve submitted all of the chapters, and it’s SO CLOSE! All of the full chapters have no issues, but for some reason, the following entries all have RMS issues being too low (and registering differently than when I run my ACX check in Audacity):
“Opening Credits”
“Closing Credits”
“Retail Audio Sample”

It can’t be a coincidence that these shorter files are having this issue pop up, especially because, with the exception of the closing credits file, which is just me saying “the end,” the other two are literally just trimmed sections from larger chapter files, which have no issues…

Attaching screenshots of the ACX’s Audio Analysis page vs my ACX check in Audacity
Screen Shot 2020-06-18 at 5.48.58 PM.jpg
Screen Shot 2020-06-18 at 5.47.24 PM.png
Any idea what the issue might be? Can’t wrap my head around why the results would be different like this, when all other settings are identical.

the other two are literally just trimmed sections from larger chapter files

I think I got it. Each individual thing you submit has to pass ACX Check. It’s not a guarantee that each slice from a chapter which passes will also pass. Particularly with RMS (loudness) which is kind of a rolling average. If you have a relatively quiet, expressive, theatrical portion of the reading and decide to make that into its own file, that will almost certainly fail loudness even though the whole chapter passes OK.

If you check the “The End” file by itself does it pass? I’m betting you’re going to get the same “off” numbers they did.

Master and check every individual performance or file you submit.

While you were doing that, we changed ACX Check. You can get the new one from here.

It’s very different. It has an abbreviated information panel and it’s faster.


There’s one other possibility. Post the “The End” file exactly as you submitted it.

Scroll down from a forum text window > Attachments > Add Files.