Crossfading effect 'broken'


I am using Audacity for many years and I am very happy with it.
My current version is 2.4.2 on a Windows 10 Pro 64 bit system.

But since I’ve installed version 2.4.2, I have a problem when applying one of the effects.
It concerns the Crossfading effect. This causes an error message, telling me that I am using more than 1 track, while I am obviously using only 1 track at the time. In the past it worked perfectly normal.

I am guessing that something got corrupted, because in the last couple of versions before 2.4.2 (I forgot the exact versions), it did work as expected, but there was a peculiarity: I had 2 entries for each effect (so, each effect had a submenu of 2 items, each exactly the same).
When using the crossfading effect, it worked only if I chose the 1st entry. If I chose the 2nd entry, I got the same error message as I wrote above.
For every other effect, my 1st and 2nd effect entry both worked in identical way.

Now, since installing version 2.4.2, I have only 1 entry for each effect again (the ‘normal’ situation) as was also the case in earlier installed versions.
And so now, I am not able to use the crossfading effect anymore.

I already tried to uninstall and re-install Audacity, and I have also reset the effects, but his didn’t solve the issue.

Any ideas?


There are two crossfading effects:

Crossfade Tracks:
Crossfade Clips:

Thanks for your reply Steve.

Yes I know, my problem concerns the crosfading within 1 track.
So, even when I have obviously only 1 track open in an Audacity window, and I try to crossfade, I get the message “more than 1 track selected” .
Just to as a comparison, if I then use the other type of crossfading on the same opened track, it says “only 1 track selected”.
That makes a lot of sense, but it is a strange contradiction.


To be totally clear, are you referring to the “Crossfade Clips” effect?

There is no such message in the Crossfade Clips effect.
What exactly is the error message?

Hi Steve, yes I am referring to the Crossfade Clips effect.
When I do that with only 1 (stereo) track opened (and selected), I get the message (translating from Dutch): “Error. Invalid selection. More than 2 audioclips selected”.
And to repeat what I wrote in my earlier message, before, in earlier Audacity versions, it did work as expected.

If I use Crossfading Tracksx(in the exact same situations as above), than I get the message: “Error. Select 2 or more tracks to crossfade”. (Which you would expect, when trying to crossfading 2 clips within 1 track).


UPDATE: I decided to do a clean re-install and chose English interface instead of Dutch, and now the Clossfade clips works again as it should.
Strange right?


I just changed my language on Audacity 2.4.2 to “Deutsch” and received no error with Crossfade Clips. (Windows 10)

Same with “Nederlands”.