Creating gapless playback for digitization, not CD ripping

I have several Audacity projects of a single concert. I create labels to divide the songs up and don’t leave any break between songs; in other words, if song 1 ends at 5:28, song 2 starts at 5:28.
In theory, this should create gapless playback – however it does not. I have seen a similar issue come up before in the forums but the only response had to do with how to deal with this while burning CDs (namely, creating cue sheets).
I don’t want to burn CDs – I just want my digital tracks to play without a small millisecond of silence between each track.
It seems that there must be a way to deal with this but I can’t find one anywhere.

Interestingly, I found a really laborious workaround via iTunes, which is outlined in a Lifehacker article:

The Lifehacker piece points to Audacity as a tool for accomplishing this much easier, but it doesn’t provide any info on how to create gapless audio in Auduacity. Here’s the crux of it:

Assuming you’ve already imported the long album/track into iTunes, here’s what you need to do. First, listen to the track and write down the start and end times of all the songs you want to split out. Once you’ve got that list, you’re ready to start splitting up your track.

Now right-click the long track in iTunes and select Get Info. When the info window appears, click on the Options tab. In this tab, you should see two checkboxes labeled Start Time and Stop Time. Enter in the start and stop values for the track (most likely with a start time of 0:00 for your first track), making sure the checkboxes next to both start and stop time are checked, and hit OK.

Now that you’ve set a start and stop time for your first track, you’re ready to split it out to a separate track. Right-click the long track, but this time select Convert Selection to MP3. iTunes will create a new track with the same metadata (so you’ll want to go in and change it to reflect the new track title), but it will only include the section you defined with the start and stop time.

From here, just wash, rinse, and repeat on the original long track with the start and stop times for each track as you originally wrote them down.

Granted, this isn’t the only way you could accomplish your goal; other tools, like the previously mentioned Audacity, are great for this kind of task. But if you want to stick with working in apps you know, this method should work without too much hassle in iTunes.

There’s no longer a “Convert Selection to MP3” option. Instead, what you need to do is go to File/Convert/Create Apple Lossless Version and do that for each individual track, and then go back in and do it over again for each song. It’s a pretty big pain in the butt – and I still think there must be some easier way to accomplish this in Audacity itself.

There never has been.

There’s an article in the Audacity manual about splitting a long recording into separate tracks:

Note that one of the limitations of the MP3 format is that it always adds a bit of padding to the start of the file. This makes it impossible to achieve gapless playback without the media player performing tricks to compensate for this padding (by slightly overlapping the start of the next track with the end of the current track). Formats that don’t have this limitation include: WAV, FLAC, Ogg, AIFF.

Sorry; I should have clarified; there used to be a “convert to MP3” option in iTunes. What I was referring to was the instruction in that Lifehacker piece to choose the “convert to MP3” option from a drop-down menu. The padding that MP3s add in is not the issue here.

I’m trying to create lossless tracks. I’ve read the manual about splitting it into separate tracks. Using that method is exactly what produces the brief moment of silence in between tracks. (I’ve been exporting into FLAC and then converting the FLACs to m4a files, but it doesn’t matter what format you export to. Note that at that top of that page in the manual it says:

Live recordings versus studio recordings
Sometimes songs on live recordings flow together. If you want to split a live recording into songs without any audible break between the songs on the CD you must use burning software that can set the “gap” or “pause” between tracks to 0 seconds and can burn in “disk-at-once” (DAO) mode. See Gapless burning.

But as I said, I’m not burning CDs - I’m trying to export digital tracks.

I suspect the problem may be with your media player.

These two files do match up exactly. If you set your player to play one after the other, it should be gapless (it is on my media player, but I’m on Linux). If there’s a gap between them, it’s your media player.

It’s not my media player – I tried the files in both iTunes (which supports gapless playback) and in VLC, and tried it using both FLAC and m4a files. (I’m on a Mac, but I don’t think that matters.)

What media player are you using on Linux? And is it possible there is some setting that I’m missing in Audacity that is inserting these micro-silences?

I do know that this is a topic that has come up previously – both in the Audacity forums and elsewhere. I spent a while searching for variations of “gapless” “exporting” “labels” “Audacity” “tracks”, etc, and this is something that I saw a bunch of chatter about but no solutions.

Did they play the tracks as a continuous rising tone with no gap or glitch at the change over from “first” to “second”?

I’m currently using “Gnome MPV”.

Those did play as a continuous track after I converted them to mp4 files and opened them in iTunes – there was no gap or glitch in the changeover from first to second – so it’s not the media player.

I’m coming back around to there being some hidden setting or something in Audacity that is adding in the padding since you can divide tracks (using labels, right) and they play continuously for me – but I can’t for the life of me figure out what that could be.

There’s no hidden settings that do that.

If you can give precise step by step instructions, I’ll see if I can reproduce the problem. So far I can only reproduce the problem by exporting in a format, such as MP3, that I know will give small gaps.

First I’m recording a large piece of audio onto Audacity from the web – around 75 minutes. Then I go to edit labels and create labels for the individual songs, with the previous song ending at the same time mark as the next song is beginning. The I select each newly created label within Audacity and go to File/Save Other/Export Selected Audio for each individual song. (I’ve also tried Export Multiple just to see if that fixes it.) I also export the entire file using “Export Audio,” and the format I’d exporting all of these in is FLAC.
That leaves me with one large FLAC file of the entire recording and then an additional 10-ish flac files of the individual songs.
I use XLD to convert the FLAC files to MP4, using Apple Lossless as the Output Format (with sample rate and bit depth both set to same as original, not that that makes a difference.) That leaves me with a series of M4A files which I import into iTunes – and leaves me with micro gaps between each song.
The same issue occurs if I convert the individual FLAC files into the VLC player, so the issue doesn’t seem to be with the encoding or with the translation to iTunes.
While playing the files continuously, regardless of whether I’m using VLC or iTunes, it’s clear that there’s not an actual gap in the music at all.
Does that all make sense? Happy to provide any more details.
FWIW, I’m using Audacity 2.2.0, XLD Version 20170729, iTunes 12.7.1, and am running High Sierra (10.13.1) on my Mac – although as I said, I don’t think the issue is with XLD or iTunes.

It sounds like you are using “region labels”. Try using “point labels” instead. Then “Export Multiple” based on labels.

I use a similar procedure. I export to AIFF (complete with metadata) then import the AIF files into iTunes. Then, within iTunes I convert to MP3. I have not experienced gaps in the playback.

iTunes still has the File > Create New Version > Create Apple Lossless Version menu choice. The menu choice you get there depends on your setting in iTunes > Preferences > General > Import Settings.

– Bill

That was it – I was (unknowingly) using region labels. Thanks so much for working this through with me – I really appreciate it. There’s no chance I ever would have figured that out. I really appreciate it.