crashing audacity

I have been using audacity on my Mac mini without problems. Recently audacity crashed and when I want to start audacity now I get an error message that audacity is already running and that it is impossible to start the program twice without problems. I try to stop audacity and then it says that the program stopped unexpectedly.
Whatever I try: I can’t get audacity running again.
Does anyone know solution to this?
Or can anyone direct me to an earlier Post that describes this problem?
Thanks for your help,
Night Owl

Restart the Mac or kill Audacity in Applications/Utilities/Activity Monitor.

What were you doing when Audacity crashed?


Alas….; it isn’t that simple….
Of course I restarted my Mac. I even tried to set it back to an earlier date with Time Machine.
Both did not work…

Audacity does not show up amongst the list of programs running on my Mac in Activity Monitor.
So I can’t kill it…

I was writing a recorded song to a .wav file when Audacity crashed.
It started playing that tune at the same time, but that stopped by itself.
Then the damage was done…
The file was saved, but I could not start a new task in audacity anymore.
Did not do any other task at that moment.

Thanks for your help and ideas anyway.

Night Owl

How old is the Mini and which OS are you using? My Mini is about two years old and I have OS-X 10.9.5.

Make it give you the error message again. Do a screen capture with Command-Shift-3 and post the picture here.


Everyone assumed you saw the “Audacity is already running” message. If that is what you saw, Audacity must be visible in Activity Monitor, unless your OS X is completely broken. Did you try sorting the columns in Activity Monitor?

You can also kill an application using the terminal.

To ensure Audacity can’t start when the computer boots, remove Audacity from your login items and when you ask Mac to restart, uncheck the option to reopen windows.

Normal Audacity does not do that either. Are you sure you got it from Audacity ® | Downloads?


Permanent link to this post Posted by kozikowski » Tue Oct 28, 2014 10:03 pm

How old is the Mini and which OS are you using? My Mini is about two years old and I have OS-X 10.9.5.

Make it give you the error message again. Do a screen capture with Command-Shift-3 and post the picture here.

My Mac mini is about 18 months old.
I run OSX 10.8.5.
It has a 2.6 GHz Intel core i7 processor and 16GB DDR3 memory.

Here are the screenshots:
Schermafbeelding 2014-10-29 om 00.03.53.png
Think posting works… :slight_smile: It is in dutch though… :smiley:
It says: Audacity already started. Having two copies of Audacity running will lead to loss of data or to a crash etc.

The only way to get rid of this message is to force a stop. (and Yes: NOW it is visible in Activity Monitor, but after forcing the stop it isn’t anymore…)

And then I get the following message:
Schermafbeelding 2014-10-29 om 00.04.14.png
It says I stopped Audacity by force. Rapporting doesn’t do any good.
Negeer means " ignore". and if I click that I am back to square one…

THEN audacity does NOT show up in Activity monitor anymore so I can’t stop the part that is apparently running…
Restarting the Mac after that doesn’t help.

On the internet, nobody can tell you’re Dutch. Isn’t that where they make hollandaise sauce? Ba-dump, Tish!

OK, so that’s extraordinarily unusual. Is there anything unusual about your machine? Are you dual-boot with Parallels or some other program? For a while I ran a Mini primary boot on a FireWire drive. I never booted into the internal drive.

Do you remote login? I mean ever, not just now.

Disconnect your network, close WiFi, and shut down BlueTooth. Restart. Does it still do it?

I intentionally have two Audacity versions on my machine (attach). This only works if I put one of them in a unique folder under /Applications.

What does yours look like?

Screen Shot 2014-10-29 at 18.44.37.png

I don’t think there is anything unusual about my machine.
It is not dual-boot.
I once used a program (TeamViewer) for remote access at the time I changed from PC to Mac.
Needed some help from a friend.
But I never used that anymore after that.
I hate to open up ports of my router cause I am a bit of a privacy freak.
(That is also why it doesn’t show I am dutch… :wink: )
I disconnected my network, closed Wifi and restarted.
(I left Bluetooth on as my keyboard and mouse are bluetooth….)
No change.
Your last remark made me reconsider, though.
I upgraded some time ago to a newer version of audacity and installing it did not remove my old files.
So there was an audacity executable outside my audacity folder.
It might be that here the problem originated.
After the problems started I removed ALL the audacity files (for as far as that is visible anyway…) and re-installed Audacities newest version.
That did not help, but it also might have put me on the wrong track as I did not see this old version anymore….
Do you think it might be possible that there might be hidden files of an old audacity version that are still running somewhere?
I think I would like to completely remove audacity and restart from scratch.
What is the most effective way to completely remove everything in connection with audacity?

Night Owl.

Good. That shows that Activity Monitor is working.

At the point you see the message that you force quit Audacity, it isn’t running. Or shouldn’t be.

If you restart the computer (unchecking the option to reopen your previous windows) and ensure Audacity is not in your login items in System Preferences, then Audacity cannot run of its own accord after reboot.


If you would uncheck the option to reopen windows on restart and remove Audacity from your login items, then Audacity cannot start itself on restarting the computer.

If you install a new version of Audacity to a new folder, the old Audacity folder or files still exist. Drag the old Audacity folder or files to Trash if you do not want the old Audacity.

Uninstalling or reinstalling Audacity does not remove or reset its Preferences settings file, which is called audacity.cfg.

Restart the computer (follow the instructions above to prevent Audacity running on restart).

Use Spotlight to find your visible Audacity folders and files and trash them.

Open Finder, choose Go > Go to Folder and type:

~/Library/Application Support/audacity/

Open audacity.cfg in TextEdit. Select all the text and delete it. Then type the following at the top of the file:


Save audacity.cfg. Reinstall Audacity from Audacity ® | Download for Mac OS. When you launch Audacity it will run with factory settings.


Yes!!! :smiley:
Got it going!

Audacity was NOT in my login and it did NOT load on startup.
Checked both and that did not alter the problem.

Got rid of al the audacity files as you suggested.
(Had done so before and that did not help then…)
Then I deleted the .cfg file as suggested and that did the trick! :smiley:

I found two rather strange things, though.
1- with spotlight I came across a directory “audacity 1.2.6-test” that I could not remove. Cannot remember installing that one…
It is still on my system I guess. Can I leave it there?
2- I downloaded Audacity 2.0.6 and it is in dutch now! Looks more advanced and it changed its language!
I had Audacity 2.0.6 on my system and I thought I was running it… Appears I was not?…

Well… I wonder what was wrong, but the best is that it works again!
I am really grateful for the help you guys gave me.
Thanks a lot! :stuck_out_tongue:

Oh, and if you need a recipe for Hollandaise sauce: let me know! :wink: :smiley:
Greetings from Holland!
Night Owl

I suggested deleting the contents of the .cfg file and replacing that contents with


Deleting audacity.cfg will also reset settings, but only if you never had Audacity 1.2.x running on your system.

What was the error removing it? It won’t do any harm, but it suggests that to be completely sure you reset the 2.0.6 preferences you should have done “NewPrefsInitialized=1”.

Only download Audacity from Audacity ® | Download for Mac OS then you can be sure what you are getting.

When you delete audacity.cfg, that makes Audacity run in the language your system is in (unless you actually ran 1.2.6 in the past in some other language).

If you want to run Audacity in English, open Audacity > Preferences, go to the Interface tab (five items down in the list on the left) then on the right, find the language dropdown menu and change it to English. Most items will change to English at once but you should restart Audacity to fully complete the language change.


Hi there. Apparently I have the same problem, and I DO NOT HAVE MULTIPLE COPIES OF AUDACITY!!! I have tried everything and IT STILL DOES NOT WORK!!! Help me please.

Please do not shout in CAPITAL LETTERS, even if you are frustrated. :wink:

The fact is - we can’t do a thing to help you without you answering the questions in the pink panel at the top of the page and without you describing the exact symptoms you experience "I do 1, 2, 3 … then … ".

A good start may be to get Audacity 2.0.6 from us at Audacity ® | Download for Mac OS and then follow these instructions to the letter Installation: Do NOT run Audacity from the DMG!!!!