Crackling Sound When Recording (No evidence of clipping)


I seem to be picking up a strange crackling sound when recording a mix.

Im using two Numark CDJs and Numark M4 mixer, straight into an Imac via a phone to Jack line in. I can’t see any evidence at all of clipping at all in the recording, I have the gains down very very low. If anyone could suggest why this might be would be massively appreciated. Would it be worth getting an interface,?

Attached is a clip of the noise:



There are bits like this (zoomed in very close) that are producing little clicks:
These discontinuities in the waveform are due to digital errors, most likely to have occurred during recording.
What is the “phone to Jack line in” that you speak of?

Ah cool, cheers:

That’s the cable, to the line in on my Imac. Any idea how I would be able to correct it?

I don’t use Macs, but it looks like the problem is in your Mac, so we’ll need to wait for one of the Mac guys. The first thing they will ask you is exactly what type of Mac you have (model number?) and which version of OS X. You can save a bit of time by posting that information now.

The next thing they will ask is “what is the exact three-section version of Audacity from Audacity > About Audacity and whether you obtained the .dmg installer or the zip.”

Say, JB. What is the exact three-section version of Audacity…


Interestingly, the damage is rather similar to the damage that this user was getting:

This is from JB14’s recording:

This is from the Windows PC in the other topic:

Thanks, man. Hopefully this is the correct info:

20inch Imac early 2008: OSx 10.9.4

Audacity 2.06

Pretty sure got it from the DMG

We do not make a “2.06” version. If that is not a typo, please obtain 2.0.6 from us here:

Don’t record into a track that had previous audio that you have now deleted. Reboot, and launch Audacity again.

Try Audacity > Preferences… then the Recording section, and try adjusting Audio to buffer (increase or decrease it to see if it helps).

Have you turned as many other apps and processes off as you can before you start recording?


Yeah sorry, was a typo. Yeah its pretty much running alone as I don’t use that mac for anything but recording,

I just ran the audio sample in that other thread through Brian Davies’ ClickRepair and it fixed it up pretty well …


So I just tried ClickRepair on the sample posted in this thread - worked well there too:

See this sticky thread on ClickRepair:


OK so if you have not already done so I would recommend playing with Audio to buffer in Audacity Preferences.

Also don’t get extravagant with sample rates. Set Audacity project rate bottom left to 44100 Hz or 48000 Hz then go to /Applications/Utilities/Audio MIDI Setup and setup the built-in audio input for the same rate you chose in Audacity.