Crackling/Clicking/Tapping noise on Audio [SOLVED]

Split from

I’m having exactly the same popping/clicking problem. It made me wonder whether I’m recording audio too hot, but that’s not the case at all. The noises are intermittent, with no known pattern.

All I know is, I’ve never had any previous problems with Audacity. This problem began happening right after I hooked up a new Behringer mixer/audio interface. I thought maybe it was a microphone problem, but it’s not. I made sure of that by recording and playing back on Reaper…no noise whatsoever. But I’m used to Audacity and I’d like to stick with it. I’m using a Windows 10 PC. Is there some kind of setting I’m overlooking?


We can’t deal with multiple people with different equipment and operating systems in in the same topic, so I started a new topic for you in the Windows board.

Are you certain the noises are in the recording or is it Audacity playback? If the noises are in different places each time you play the recording, then it’s a playback issue. If it is a recording issue please post a sample of the noise. See How to post an audio sample.

Are you podcasting? Overdubbing?

Model number of the Behringer interface? Make and model number of the mic? Is the mic connected to the interface somehow? What playback device are you using in Audacity? Did you change anything else?

Did the machine come with Windows 10 in the first place or have you updated it to Windows 10?

This might help - perhaps a sample rate mismatch, depending what you are doing


My apologies for the lack of specificity.

The machine was initially Windows 8, upgraded to 10. The pops were contained in the recording, as they’re in the same places each time I play it back. It’s version 2.1.2, downloaded two days ago. I downloaded the .exe file.

I’m recording files for broadcast on radio stations. The Behringer interface is model Q1002USB (But as I mentoned earlier, everything works fine when I use Reaper, so it’s not the interface). I listen to the playback through the board and a pair of Sony MDR-V6 headphones. The mic is a Behringer B-2 Pro.


Please see the link I gave. The solution is almost certainly to do with sample rates. They are either mismatched, or too high, or perhaps you need to increase “Audio to buffer” in Audacity’s Recording Preferences.

Also the Audio Host chosen in Device Toolbar can make a difference. MME is most compatible, but if you need to make changes in Windows Sound to match rates or set exclusive use of the sound device, you are better to choose Windows DirectSound or Windows WASAPI. More explanation here (it applies to Windows 10 just the same).

I don’t know if Reaper can choose host but it may help to look at its recording settings to see what works there.


Well, problem solved. I uninstalled Audacity and reinstalled it…everything’s fine.

It was getting very frustrating, as I checked every setting I could find. In fact, after I adjusted the record and playback volume controls, it sounded REALLY bad, for some reason. But it all works as it should now.


Thanks for letting us know. :slight_smile:

In case it helps in future, when you uninstall Audacity and enable the “Reset Preferences” box half way through installation, this resets all Audacity settings. If you don’t enable that box, nothing changes at all as far as Audacity settings are concerned.

If you rebooted, that can make a difference to USB devices. If you never reboot they can end up recording a flat line, or producing an error, or (occasionally) producing ticky audio.


Thanks much, Gale.