"Could not save project. Perhaps $PATH is not writable..."

Having trouble with Audacity 2.2.1 (and 2.2.0 before it) on Debian.

I have over 200 GB available on the hard drive in question. Standard permissions on my home directory. I open an MP3 file to edit. Choose “Save Project” from the file menu, place the file somewhere in my home directory. I get the following error message in a window:

“Could not save project. Perhaps [the file path in /home/] is not writable or the disk is full.”

I am able to continue editing and export the final product as a sound file of whatever format … but I can’t save the project (.aup file).

Any help appreciated. Thanks!

Ensure that you are giving it a legal file name. In particular, don’t use the “/” character.

Thanks, I did that already (just to be extra sure, I only used ASCII alphabet characters and no spaces.) Same problem persists.

I’ve re-read your first post:

That’s correct. For a standard user account, the file path /home/ is not writable. Your “Home” folder is “/home/username/” where “username” is your log-in name.

Sorry for the ambiguity. I was not trying to save in /home/ itself, I was trying to save in a subdirectory of my home directory. I have the normal read and write permissions. Other programs that I run, e.g. a text editor, are able to create and write files in the directory in question.

OK, so we will need to get down to the fine detail, because obviously “something” is wrong.

If you shut down and restart Audacity, then generate a 30 second tone (Generate menu), and then try to save the new project as “my-project” in “~/Desktop/”, what happens?

I followed your steps exactly, and was able to save the .aup file in ~/Desktop without any error.

I did a little further troubleshooting:

First, I exited the program and re-opened my-project.aup, everything worked as expected.

Second, I exited he program again. Restarted the program with a blank/new project. Imported (from the file menu) the original audio file in question, a 107 megabyte MP3 file. I tried to save the resulting project (two tracks, just under two hours) in ~/Desktop as my-project-2 . Got the same error.

How much available space in “~/”?

$ df / reports
261999448 used, 222405624 available, 55% used.

$HOME is on the same root partition.

Can you try with a different large file to see if the problem is specific to that MP3.

Ok, I opened a similar but not identical file, an ~88MB MP3, stereo, approximately 1.5 hours. Imported into Audacity successfully. Did not do any actual editing. Save project, again a “simple” file name in the Desktop directory … same error.

P.S. I apologize that I can’t share the specific files for debugging purposes. The project involves editing down a recorded classroom session, with discussion etc., into a smaller file that’s just the main lecture. For privacy and other reasons, I can’t share the files.

How are these large files made? Are they Audacity recordings or something else?

Hi, sorry for the delay. The files are recorded on various devices, usually cell phones with some kind of tape recorder app, producing stereo mp3 files. I open them in Audacity, mix them down to mono and edit them down to particular segments to be exported as smaller, more compressed audio files. Again, I am able to export the resulting audio files, but am not able to save the project (so I have to start all over again if I exit Audacity).

I have over 200 GB available on the hard drive in question.

Remember that? How many drives do you have and how full are they?

I’ve been burned with this. One mounted but forgotten drive was almost full and created chaos in the machine, even though it wasn’t being used for the show.


Yes, I have one active (non-backup) hard drive, just checked again to be sure,

df /

reports the following:

1K-blocks Used Available Use% Mounted on
486432768 270941136 213553792 56% /

So that’s probably not it.

Does it still do it if you reverse the tracks top to bottom? This is fact-finding. I’m not obviously trying to solve the problem.


I do appreciate your help very much. Unfortunately or not it’s a very simple production. There is only one monophonic track.