Could Not Open Mp3 Encoding Library

Interesting turn of events folks. I put a lot of my VST plugins back into the folder and guess what? Mp3 encoding issue cropped up.

Is there a limit to the number of files in the plugins folder? I currently have 151 items in there. I have done this one by one, scanning for VST each time I open Audacity. Files left that keep causing the MP3 error are the following:


Seems when I put one or a couple of these into the Plugins folder I get the error. Looking at the dates on some of these dlls, they are 2006 so it’s probably time to get rid of them anyway.


I don’t think so. At one point I had well over 200 plug-ins installed with no problem.

Do you know what those dlls are? wave_terrain_1412.dll sounds like a synthesizer.
I think that vynil_1905 may be one of the iZotope effects.

Are you saying that it is only when there is a combination of these effects that the problem happens, or that you have so far narrowed it down to these?

You should be able to install LAME into the normal Windows Program Files (x86) directory.

Those are the swh LADSPA plug-in set for Windows.

I have tipped all those and another 100 LADSPA plug-ins for Windows into the Audacity “Plug-Ins” folder and I can still export MP3.

The DWI file you sent was for lame_enc.dll 3.98.2 so not the currently recommended version.

If this is still a problem with the recommended LAME can you please send a DWI for that ( ) .

Could this be something to do with your building the computer yourself?


I didn’t think there would be either, mind you 150 is quite plenty for what I need to do! I really should thin them out to the 10-20 most used.

If I put any one of those in (e.g one at a time, open audacity, rescan plugins), I then get the error. These files I have had for a long time and I wonder if they are causing a conflict simply because they are old. Audacity is working fine without them and to be honest, I don’t miss these plugins. Probably never used them!

Unlikely. I’ve been building PC’s for years. Am an electronics service tech and A/V tech. PC’s these days are plug and play anyway.

That’s strange as I was sure I had the latest one on. I had run that DWI before I uninstalled everything. So now on my system is Audacity and that Lame version you linked. I ran DWI but still got the same error of not finding that IESHIMS.dll and that’s with Audacity working fine.

I am happy to leave it as is now and just not include those few plugins and put it down to something weird.



The lack of IESHIMS.dll doesn’t stop lame_enc.dll working - it’s cited in DWI’s where lame_enc.dll works fine.

At the point when you add one of those LADSPA plug-ins and this stops lame_enc.dll working, are there any other DLL’s in the Audacity plug-ins folder?

Note that rescan is only required for VST plug-ins, even though the scan will see and ignore LADSPA DLL’s. You only need to restart Audacity after adding a LADSPA plug-in (like the ones you mentioned with numbers in their name).

If and when you have time and patience, suppose you have only the plug-ins Audacity shipped with (including the three LADSPA DLL’s GVerb, Hard Limiter and SC4). Now add one of those plug-ins you mentioned with a number. Restart Audacity but don’t rescan. Can you still write an MP3?


I may not get to that right away as thats a bit of a time sync and my week is HECTIC! We’ve had a end of day light savings change today and Im about to start a night shift AV install for three nights :frowning:

I’ll put it on my to do list.