Corrupt or Otherwise Broken Audacity Project Recovery

So that is a big file. I would take a look at the file but how would you get it to me? And how would I get it back to you?

Perhaps you can copy the entire “cmd” output screen, paste it to a text file, then post that.

Do you have sufficient free space on your machine? And don’t try this using a network’d drive.

Thanks for the word. :smiley: :smiley: :smiley:

does anyone know where the exe files are, Ive downloaded the tool but not a single exe file is in there.

Did you download " " from Release 1.0.1 · audacity/audacity-project-tools · GitHub ?

The zip file contains audacity-project-tools.exe and sqlite3.exe nestled neatly inside of a audacity-project-tools-1.0.0-win64 folder.

You many need to go to Windows File Explorer > View Tabs > and Check the “File Name Extensions” box to see the .exe file extensions.

After repairing the laptop, I had to download the application, but for some reason the audio recording comes with an echo and sound playback. Advise what to do?

This post is not relevant to this topic and is a duplicate of this post here: эхом и искажением звука

which has been answered.

hey there @jademan, I’m at a complete loss right now with one of my project files. The drive I was recording to got disconnected mid-session and it looks like everything is lost. I was able to find one file in the session data folder but have been unsuccessful recovering it. Every command gives me the “database disk image is malformed” error. I was able to run “-recover_db” however when I try to open the file or run any more of the recovery commands I get the error:

“Project requires Audacity 21.149.85
Unsupported project version”

At this point I’m pretty sure I’m SOL, but if there’s any way you know how to recover any audio I’d be eternally grateful. Thanks again.

EDIT: link to file Corrupt Audacity File - Google Drive

So the link for “Unsupported Project Version” from Corrupt or Otherwise Broken Audacity Project Recovery was apparently lost as a result of the forum migration, @LWinterberg, but you should be able to find the solution in the last post here: Recover project - Audacity 80.156.6

I was wondering if I could send you an audacity file of mine that was suddenly corrupted. I’m not very good with coding and such.

Just so you know, I am NOT doing this anymore. If you want to make a general plea, I suppose you could post your .aup3 somewhere and someone else might take a look at it. Good luck. You could also try Discord: Audacity

  1. Type “audacity-project-tools -drop_autosave broken.aup3

You are amazing!!! THANKS A LOT!!!
It worked!!!

Hi I am really not good at this BUT fought my way through only to get this message.

C:\Users\Steve\OneDrive\Desktop\Audacilty\AudRepair>audacity-project-tools -drop_autosave broken.aup3
Project requires Audacity 3.1.0

It would seem that the tools are not updated for version 3.3 :(:(:(:frowning:

I have to start all over…

A sad day - any other help available??


This is an informational message, NOT an error. Because the project database has an underlying XML format, the recovery tool operates independently of project version.

Hello, I need help. I’ve tried following the instructions and downloaded the audacity-project-tools from github, but i cant find any .exe files in the zip folder. Yes, extensions are visible. What do?

So what did you find there? Did you look in the subdirectory ?

I created an account just so I could say that this was an amazing post! I’ve been using audacity for my podcast and had just completed hours of editing, when Audacity crashed and my file was corrupted. I don’t code (though grew up in the era of DOS games) and these step by step, immaculate instructions saved me hours of work, cursing, and hair pulling. Thank you, you benevelont human!

@jademan can you please try to recover this aup3 file?

I have been also tried, but after process the sound track is totally empty, this is a very important file for me, so please help me
Thank you!

At step 9 I get the message “database disk image is malformed” so I skipped ahead to step 12, where new errors appeared, including “Database is badly broken.” I’ll look a little further tomorrow. Is this the only copy of the database you have ?

So there is nothing further I can do with this project. If you don’t have a backup, let me suggest that you re-record the whole thing.

If you are die-hard for punishment, you can use the “-extract_sample_blocks” option to recover your project in 650 neatly unorganized .wav files. Although this process at first might seem appealing, it could take hundreds to thousands of hours to reconstruct your project. And then you don’t even know if it will be complete. :frowning_face: You are on your own here.