Convoluted Launch Routine

Equipment & Version Specs:

  • Computer: Dell XPS 15 9500
    Processor: Intel(R) Core™ i7-10750H CPU @ 2.60GHz 2.59 GHz
    RAM: 16.0 GB
    System: 64-bit operating system, x64-based processor Windows 10
    Audacity Ver: 3.1.3
    Drivers: All current as of this writing

I’ve been using Audacity for many years with no problems. Recently purchased new computer (above). Loaded & deleted Audacity many times. Most current loaded: 3.1.3

Here’s what happens when I try to launch Audacity as Administrator using Windows 7 or 8 Compatibility Mode.

    1. Audacity launch screen appears and promptly disappears
  1. Must go into Task Manager, find Audacity, and End Process
  2. Launch Audacity second time
  3. Wait 1 to 3 minutes for Audacity to finally launch
  4. Inspect Taskbar to discover Windows Audio Service has been “Stopped”
  5. Use Task Manager to “Restart” Windows Audio service
  6. Continue with Audacity as normal.

Everything seems to work fine from this point on unless and until I exit Audacity. Once Audacity exited, I must repeat all above steps in order to regain use of Audacity.

Am I the only one having this problem? Does anybody have any suggestion(s) what might be causing this? Or what I might do to remedy the situation? This is aggravating and time-consuming.

Thanks for whatever help you might be able to offer.

Am I the only one having this problem?

You missed the step where you tell us why you’re using Windows 8 compatibility mode in Windows 10.


To be perfectly honest - - - the answer is DESPERATION!

I’ve been trying everything and anything to solve this problem.

In truth, I never used Windows 8. I went directly from Windows 7 to Windows 10. Audacity has always worked just fine for me under every OS I’ve ever had - - - until I bought the Dell XPS 15 9500. I’ve tried to get answers from Dell but, so far, they have been non-responsive.

Let me take a stab at it.

You bought a new laptop running Windows 10 and Audacity didn’t work. So you thought you would try Win7 Compatibility Mode and that’s where we are now?



That fairly well sums it up :cry:

I’ve been trying absolutely everything I could think of.

Audacity ran just fine under Windows 10 on my Dell Inspiron. It wasn’t until I put it on the XPS 15 that the problems began. Unfortunately, the Inspiron has “given up the ghost” and I can’t even get that computer to boot any more.

In the interest of full transparency - - - - there IS one other application that also won’t run on the XPS 15: Movavi Video Suite – which I have also been using for a looong time. I have been in touch with Movavi and they’ve exhausted everything they can think of trying to solve the problem. They finally just issued a refund of what I paid for the software. All other applications are running without any problems on the XPS 15.

I know Audacity is not the only DAW available to use. But I know it, like it, and have a ton of products produced with it that I can’t access until I can get consistent access to it. It’s GOT to be something connected to the Dell XPS 15 9500, its firmware, or some such thing.

You could revert to one of the older versions of Audacity

Thanks for the suggestion.

I’ve tried every version all the way back to 2.4.2 - - - - same results. Won’t launch . . . .

I found this suggestion elsewhere on the forum:

“Open up your task manager. Click the services tab. Find ‘Audiosrv’ and ‘AudioEndpointBuilder’ and stop those files. This -should- disable your audio from working altogether until reset, and possibly will need a system reset after it.”

So I did what was suggested – disabled those two services and tried to launch Audacity.

Audacity launched instantaneously! But there were no audio setting in Audacity.

Restarting Audiosrv returned me to the old problem – no launch!

Does this shed any light on things?

Are we still trying to force Compatibility Mode to work, or are we fixing Audacity under Windows 10? Billions of people manage to get Audacity 3.1.3 and earlier to run under Windows 10. I would totally start there.

What doesn’t work?


I cancelled compatibility. Only special properties setting is “Run as Administrator.” Running under most current version of Windows 10. All drivers current as of 1/14/2022.

As mentioned above - with audio services (Audiosrv) disabled Audacity 3.1.3 flies like a champ! But contains no audio input or output settings. Ergo - - - it’s pretty well useless.

Enable audio services (Audiosrv) and Audacity goes nowhere.


A million thanks :smiley:

Something somebody suggested sparked a thought in my mind and, suddenly, things all came together.

I found the problem! Now Audacity launches like a champ under Windows 10 on my Dell XPS 15 9500 with no more compatibility issues with Audiosvr.

I appreciate all the insights that led me to the solution.

Sorry for the abrupt message yesterday evening. I wanted to get the “Thanks” out ASAP in case there were others still wracking their brains for a solution. That – combined with the fact that I was up against the clock for a family birthday dinner celebration – resulted in an incomplete reply.

The problem standing in the way of Audacity launching properly seems to have been related to a relatively new app published by a highly specialized, well-know and respected manufacturer in the field of computer audio hardware. I’m reluctant to be any more specific than that right now because I have not yet had a chance to communicate my discovery to the vendor. Plus, I am an established fan and user of their products. So I feel a responsibility to give them a chance to research and resolve the problem before saying anything further about them in a public forum.

Anyway, the thread of discussion here sparked a train of thought suggesting there was something new in my OS causing a conflict with Windows Audio Services (Audiosrv). If I disabled Audiosrv, Audacity would launch at a blinding speed. But, as mentioned before, it would appear without any input/output configuration options. This was a useless solution.

Then I went looking carefully – doing what I guess could be considered a “deep dive” – into Windows Device Manager. Under “Sound, Video and Game Controllers” I noticed an item that I knew had been installed just about the time I loaded Audacity onto my new Dell XPS 15 9500. I also knew it had been recently updated by the publisher - - - - - and it is something I loaded more out of curiosity than anything else. I really have no need for it because I don’t own the hardware it is designed to control. Plus my A/V hardware setup is several steps beyond that product anyway.

So I right-clicked the item in Device Manager and discovered a pop-up menu offering the option to “disable” that device. I disabled it and BINGO! With it out of the way Audacity 3.1.3 loads like a champ.

I plan to alert the manufacturer of the apparent conflict and see where they go with the information. If and when it’s satisfactorily resolved I’ll return here to be more specific.

Following up on my promise to reveal the culprit causing the problems on MY computer, after contacting the publisher of the offending application, the product I disabled (and subsequently uninstalled) was RØDE Connect. This is a fairly new application from RØDE Microphones of Sydney, Australia (released, I believe, in late 2021), ostensibly intended to provide a modicum of audio mixer capabilities found in their hardware offering (RØDECaster PRO).

Please understand, I am not a software engineer. I am simply reporting that several months worth of aggravation and frustrations immediately and “magically” disappeared the moment I disabled this particular piece of software that I, in truth, have no use for anyway since I do not use the RØDE hardware it was ostensibly designed and released to address.

I sincerely hope this information is helpful to anyone else suffering through the same difficulties I encountered. I welcome any questions for more information and/or my hardware configuration if that will be useful.