Content in audio tracks suddenly disappeared

Hey folks. I just spent a few hours in a studio recording and fear it may have just been for nothing. I really really hope someone can help me recover this!

I recorded everything by creating new tracks one below the other for each of the samples in the same project and, dumbly, didn’t save at any point. Too trusting of me, I know.

At one point while I was working all the sound within the tracks just disappeared. This is what it looks like now:

As you can see, all tracks are still there but empty. Nothing comes up if I try to press play and mute/unmute different tracks.

I looked at the History, just to be sure I didn’t do anything other than recording, creating tracks and renaming them - it all happened when I created or renamed the new tracks and I tried undoing all that but no help.

There’s nothing on the logs around the time where the error happened. But I have these from around when I created the project, repeated a few times:

“13:15:25: Error: dlopen(libavformat.60.dylib, 0x0002): tried: ‘libavformat.60.dylib’ (no such file), ‘/System/Volumes/Preboot/Cryptexes/OSlibavformat.60.dylib’ (no such file), ‘/usr/lib/libavformat.60.dylib’ (no such file, not in dyld cache), ‘libavformat.60.dylib’ (no such file)
13:15:25: Error: dlopen(ffmpeg.60.64bit.dylib, 0x0002): tried: ‘ffmpeg.60.64bit.dylib’ (no such file), ‘/System/Volumes/Preboot/Cryptexes/OSffmpeg.60.64bit.dylib’ (no such file), ‘/usr/lib/ffmpeg.60.64bit.dylib’ (no such file, not in dyld cache), ‘ffmpeg.60.64bit.dylib’ (no such file)”

I saved the project after the bug happened and the file size is around 650 MB, which leads me to believe there might be hope? I have not closed Audacity or the project ever since, for fear of making the damage permanent.

I’m on MacOS Ventura 13.2.1 and Audacity 3.5.1.

Please help!

Or File > Export to perfect quality WAV safety file.

I think you ran into the Audacity “backup” conundrum. When you make an edit, Audacity makes a protection copy of everything you did up until that point. That becomes the UNDO if you make a mistake.

Remember that math story of the guy who wanted to be paid by putting one grain of rice on a checkerboard, two grains, four, etc, doubling each time. That works out to more rice grains than on earth.

When you started the second track, Audacity would have made a copy of the first. On the third, it would have copied One and Two. Etc. So by the fifth track, it would have taken more memory than in the world.

There is a clue in your graphic. On the bottom, Audacity thinks you have been recording for 9 hours and 58 minutes. So by that point, Audacity is already smouldering ruin and probably has no clean copies of your production.

Koz

So… that means my work is unrecoverable?

That would be my guess. Someone else may post.

Koz

OH MY GOD. I was looking at Audacity again not wanting to accept my fate, when I realized the timeline on the top looked weird. I tried zooming in and MY TRACKS WERE ALL THERE. I had just done a weird trackpad motion accidentally zooming out so far that everything disappeared. I feel even dumber but immensely relieved! Will leave this here for other folks who might have the same accident :sweat_smile:

So now you’re going to carefully select each track and File > Export it as a perfect quality WAV file. Do Not use MP3s.

Screen Shot 2024-06-25 at 9.13.28 AM

Staying in the Audacity Project environment after all this is just inviting troubles.

Koz