Confusion on Export Wav files

I am not a new user though I might not use all function of Audacity.
I really appreciate we have this tool to use.
Just recently I have to modify some existed PCM Wav files and mainly for data analysis not only for hearing, and then I found I suffer unexpected symptoms.
Currently I use Audacity 3.2.1.
(1) When I try to export “signed 16bit PCM” wav, I choose “WAV(microsoft)” and “Signed 16-bit PCM”) and I found the output file still get a header over 44bytes, it seems something like WavEX format maybe.
(2) Even I tried “Export Audio” and “Export as Wav” with same setting (“WAV(microsoft)” and “Signed 16-bit PCM”) and I got 2 output files with totally not bit-exactly hex.
(3) If I tried to discard wave header, which is to save as “RAW (head-less)” + “Signed 16-it PM”, then I got a output file also not bit-exactly with original wav (in the data trunk), something like a little shift on hex, like 0x0000 => 0xFFFF or FFFE etc…

I search on the Forum and general on google, also Audacity manual, while not found something similar to what I meet. For data analysis, the format/header and the exactly value of samples are equal important.
Maybe there’s some setting or some operation I didn’t notice, please advise or kindly provide link of explanation/discussion to me.

Additional info: Basically modify existed wav files without change sampling rate, byte order(LE /BE), channel number or amplification, most is to merge or split/cut wave sample on time index, then to export as a new wav file for analysis. So as my expect the new file should be “bit exactly” as original wav sample value.

Not sure, but I’m wondering if it has something to do with “dithering”.

Thanks for reply, as my understanding the “dithering” option is in the conversion item and should be happened to there is a sampling rate conversion.
I forget to mention that I modified those existed wav files without changing properties, like sampling rate or channel number.
Anyway, thanks for advice, I will still change this option to none and export to check, will reply here if found something different.

Could anyone share me how to merge multiple duration or split/cut 1 wav with “bit to bit exactly no change” output wav file ?
Please refer to my first post, which I merge different duration or even read RAW and then output RAW, while always get a slight different one when export/save to a new file.


You have to tell Audacity to dither or not. By default it converts everything to floating-point and the only thing it “remembers” is the sample rate. (The conversion from 16-bit integer to 32-bit floating-point, and back is lossless as long as dither is disabled.)

Hi @DVDdoug
Thanks for further explain. I change “Dither” to “None” in both “Real-time conversion” and “High-Quality conversion”, and finally I got bit exactly output.
Could you share where can I find the description like “By default it converts everything to floating-point” ? I don’t really find this in manual, maybe I missed out something.

And also thanks @ Ivalogic

To the left of the waveform display you should see “32-bit float”.

Almost all audio editing programs work in floating point (some use 64-bit floating point).

There is a Preference Setting but I’m not sure if it does anything… If I change it to 16-bit I still see 32-bit float.

Most DSP just “works better” in floating-point and I’m pretty sure you can’t change the way the effects work.

1 Like

Got it, indeed I always saw “32-bit float” under any import wav.
While I used to thought it’s something like display issue and not doubt it.
Thanks for this. Maybe I should spend some time to dig deeper inside the manual.

This topic was automatically closed after 30 days. New replies are no longer allowed.