Completely Stuck and confused [SOLVED]


So I know that Steve helped me before.

Previously I had 2.4.2 running before. It was a strange situation where it would only work from within the version I had downloaded and put into downloads. I could not install and run as per every other piece of software on my Linux 19.3 machine.

I have uninstalled it in anticipation of putting 3.0.0 on. When I go to add the PPA, that just seems to take me to links for 2.4.2. No 3.0.0. Fine I think, I’ll just put 2.4.2 back on. So I go back to either Synaptic or Software Manager or Terminal and everytime I try and put the old version back on, it refuses to work and gives me errors so basically I no longer have access to Audacity. Is there anything I can try as I rely on this daily and am going to have to go back into Windows until I get this sorted.

Thank you.

EDIT: If I run from Audacity from Terminal, this is the error I now get

audacity: error while loading shared libraries: cannot open shared object file: No such file or directory

but it was working until an hour ago - I have no idea how to fix this error.

Further update.

I have downloaded and installed wxwidgets 3.1.3 from source thinking Audacity 2.4.2 would work but am now getting this error message when I run from Terminal.

audacity: symbol lookup error: audacity: undefined symbol: _ZN12wxWindowBase14RegisterHotKeyEiii

I can see that there are patches to do with Audacity in WxWidgets and also that it needs to build against version 2 and not 3 of GTK but I don’t know how to get or build that version.


Followed the instructions here, using the latest build and remembering what I did last time with Steve’s help.

FWIW, Audacity can now be built and run with wxWidgets built against GTK3. Some of the text looks a bit weird, but it runs fine.
We’re not quite there yet with GTK3, but it’s getting better.
I’d still recommend building with GTK2 if possible (for now).