Completely choppy playback in Audacity

  • macOS Mojave 10.14.5

  • Audacity 2.3.2

  • MOTU Ultralite-mk4 1.3.5+241

Hi folks,

Trying to get to the bottom of this. The attached file plays a sample through Audacity and is followed by what it should sound like through an audio player app. I tried rolling back to previous versions of Audacity, but they don’t work. This is a clean install of the MOTU, it’s software and a fresh install of Audacity. I’m currently using WavePad, which works fine, but I desperately want Audacity back!

Any help would be greatly appreciated, thanks!

I don’t understand what you’re trying to say. Please describe step by step how you made that file.

I had the same problem with my Motu Ultralite mk4!

I did solve this by going under preferences > devices and then set the Buffer Length to 50ms or lower!

Thanks for sharing.

See also, How can I prevent clicky recordings on Mac?

Coming back to this with version 3.0.0 (better late than never!)
I had hoped the issue was resolved, but it seems it’s not an Audacity issue, but more to do with the MOTU. Given they’re 6-months late (so far) releasing drivers for macOS Big Sur, I see now how things work at MOTU. All they did when asked about this issue was blame macOS and Audacity. However, ragging on MOTU isn’t the point of this post: gila_crisis’ tip fixed it! I set the buffer to 50ms as suggested and playback is as it should be.
Thank you!

I recorded the output of my Mac with Audacity playing a file, then an ordinary music player app (Pine Player) playing a file. Audacity was choppy, Pine Player played the file as expected.

Audacity’s device buffer length was set at 100ms as default. I had to come down to 50ms from 100ms to solve the issue rather than up from 0ms, but same difference really. Thanks!