Compiling on Debian: wxWidgets versions and other woes

Hi all,

Just thought I’d post here since I had trouble compiling Audacity version 2.3.3 on Debian testing. I managed to get it to work in the end, but posting here in case this can be useful to other people or suggest possible improvements to the build instructions:

  • The building guide on says to run “sudo apt install libwxgtk3.0”, but on Debian there is no such package. In the end what worked for me was to install libwxbase3.0-0v5 libwxbase3.0-dev libwxgtk3.0-0v5 libwxgtk3.0-dev wx-common wx3.0-headers, all from stretch-backports, except wx-common which was from testing.
  • I also add to create a symlink to work around a missing include: sudo ln -s /usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-3.0/wx/setup.h /usr/include/wx/setup.h
  • And I had to pass config options to use the right version. Specifically what worked for me was: …/configure --with-lib-preference=“local system” --with-ffmpeg=“system” --disable-dynamic-loading --with-mod-script-pipe --with-wx-version=3.0
  • Last point, it took me time to figure out that the forum was the right resource for help with building Audacity, as linux/build.txt from the source repository contains seeminlgy relevant, but slightly outdated information.

I hope these points can help, many thanks to the developers in your work on Audacity!

libwxgtk3.0 has been updated to libwxbase3.0-0v5 since those instructions were written.

I shall be writing a new step-by-step guide when Audacity 2.4.0 is released (probably within the next couple of months).

Awesome, many thanks for your work on this!