clipping at +/- 0.5

When recording, the clipping happens at +/- 0.5 on the wave screen whereas I thought it shoud lhappen at +/- 1.0. Why is this and what can I do about it?

It all depends on where the clipping occurs.
Audacity will clip at +/- 1.0, but your microphone, pre-amp, sound card, (whatever is in your signal chain) will have its own clip level. Try fiddling with the levels at each point in the signal chain and see if you can find where the clipping is occuring. (A very common reason is when people feed a “headphone output” into a “mic input” and overload the “mic in”).

My input is coming from a mixing desk and goes via the inline socket. The inline volume is set to max so that I can adjust the sound in via the mixing desk. Not sure where to look for setting the clipping levels for the mixing desk or the sound card.

What sort of mixing desk do you have?

Steve HI,

It is a Soundcraft Spirit LX7. If that helps.


On your Windows Laptop? Those machines tend to not have Line-In in favor of Mic-In which like to overload pretty much exactly like you’re describing. Roughly a thousand to one mismatch in sound level.


That’s fine, I just needed to know what features you have available on the desk.

For each input that you are using, check the “pre-fade level” (PFL). There will be a button near the fader of each channel for selecting PFL (consult your manual if you can’t find it - this is one of the most important functions, so you need to know how to do it).

The Pre-Fade Level should meter reasonably high, but should never go into the red. Adjust the gain (sometimes called “trim”) as necessary. Note that if you adjust the channel Eq you will need to recheck the PFL.

If you are using Aux send/returns, you should check the levels of these also.

When you are satisfied that these are all correct, return the metering back to the stereo mix and gradually turn up the faders. If you are using a line input on your computer you should see a reasonably high level on the mixing desk meter as the record level meters in Audacity show a good level. You will not necessarily have both sets of meters showing the same levels as there is more than one definition of “Line Level”. Professional audio equipment usually uses a higher signal level than domestic audio equipment, so the level on the mixing desk may appear to be a bit low.

If you need to turn the mixer master level so low that it does not show on the mixing desk meter at all, then you are probably using a microphone input on the computer instead of a line level input (that will not work - you must use a line level input).

The level on the mixing desk should never go into the red.

The recording volume for the computer should be set using your sound cards control panel/mixer (or the Windows Mixer). Do not rely on Audacity to control the recording volume.

Some sound cards are designed to work best with the recording level set to around 70 - 80%, other sound cards work best with it set to 100%. You will probably need to experiment as this does not usually get mentioned in the sound card documentation.

Note that there are often 2 controls for the sound card record level. There is the “line in” level, and then there is the “master record” level.

Check that you have selected “Line in” as your recording source and not “Stereo Mix”. (in the sound card control panel/mixer).

You have not mentioned what is plugged into the mixer. Are you recording from microphones? Are you sure that the distortion is not occuring before the mixing desk?

Some PC laptops claim to have inputs that can switch between mic level and line level, but they are still usually rubbish and likely to cause problems. Making good quality recordings on a laptop invariably requires either an external sound card or a Mac.

A bit more info. I am using a desktop and line-in is selected for the sound card which is a Realtek.
The clippings happen at exactly +/- ).5, so exactly half of the normal +/- 1.0 so I cannot see it is a question of adjusting levels somewhere, more that some setting needs to change.
I have Audacity set at sample rate 22,050 and it is taking a mono signal. The sample format is 32-bit. I notice that the settings on the Realtek are 44,100 and 16-bit. Does this have an infulence?

That’s good - it means that you have more available options.

“adjusting levels” vs. “change some settings” - that’s a bit of a fine distinction :slight_smile:

If the sound is being clipped, then it is because something somewhere is being overloaded. What we need to do is to find out what is being overloaded. We can then look at why it is being overloaded and hopefully determine if it is due to a “user setting” (I’m including the concepts of buttons, sliders, switches, check boxes, and all other forms of user interaction), or whether it is due to a hardware fault (something that will need repairing or replacing).

I presume that you have checked everything already mentioned.

I also assume that the clipping is causing audible distortion when you play back the recording.

If you plug headphones into the mixing desk and listen to the main mix, does it sound OK (clear and absent of clipping)?

If so, then either;

  1. Your sound card is faulty (or just very poor) and needs replacing.
  2. You have the output from the mixing desk too high for the input of the sound card to handle.
  3. You need to adjust the record levels in the sound card control panel/mixer.
  4. The sound card drivers are faulty and need upgrading.

My money is on No.1, but it’s worth checking out the other options before buying a new sound card.

RealTek sound cards are usually “on-board” sound cards and are not really designed for recording. They will usually work well enough for making computer beeps and pings, for internet phone calls, and for playing MP3’s through little computer speakers, but not for much else. Since you have a nice mixer, I guess you are quite serious about making some good recordings, in which case a nice sound card will definitely be money well spent. You should look at sound cards that are designed for music/recording rather than game cards. The cheapest option is probably the Behringer UCA 202 (a USB line level in/out device) which is designed as a cost effective interface for line level devices such as mixing desks, CD players, tape decks, etc.

You can divide the system in half. Do you have an iPod or other music player? You can Plug an iPod directly into the Line-In of your sound card with an extension cable.

Play music and the iPod should more than drive your sound card to good level.

You can make that cable if you have two RCA/1/8" adapter cables and two couplers, etc.

There is another slightly more magic thing you can do. You know if an RCA audio connector is a little dirty or old, the show sound can pick up hum or buzz. You can use that for testing.

Plug one of those into your sound card, hold the cable by any plastic part and touch one of the RCA metal tips with your other hand. The sound meters should wake up for that channel and record loud hum and buzz. You are intentionally creating trash. If you do it right, the hum might go over 0.5, proving the sound card is OK. All the volume controls will need to be up to max to make this one work.


Thanks for all your responses. However, I found another person with this problem on the forum, Nov 2 2007 - clipping audeo input problem. The solution there was to change the audacity setting from recording mono to stereo. And it seems to work. So thats what I am going to do. Does seem a bit strange but there we are.

That’s not really a fix, it’s a workaround for a sound card that doesn’t work properly - but I guess if it get’s you going for now, then that’s good. (and it’ll give you time to save for a better sound card).


Thanks. I must say I do not know enough about the technology to understand why this works as a workaround but I will take your word for it. Interestingly, on another PC I do the same thing but without this clipping problem and that PC has a 3 year old realtek soundcard whereas the PC with the problem has a 6month old realtek soundcard.

<<<I do the same thing but without this clipping problem and that PC has a 3 year old realtek soundcard whereas the PC with the problem has a 6month old realtek soundcard.>>>

Which, in computer-speak, means you went from an old $49 sound card to a new $12 sound card.



Not so strange if you know how to run a screwdriver and soldering iron.

One way to create mono from stereo is to smash the two signals together and then divide the signal level by two. This is precisely what you can’t do because the two smashed signals will add up and overload the sound channel. Then, when you divide by two to bring the signal level back down and avoid overload, it’s too late.

You need to divide each signal by two first and then smash them together.

Bad electronic design. Something that happens a lot in $12 sound cards.