Clipped start of track saved as silence

When I use the clip handles to trim my track, then save as WAV, the resulting file has silence at the beginning where I’ve clipped the start of the track. The piece I clip at the end is gone, as I expect. To remove the clipped piece at the beginning of the track, I have to delete it, as I did before the clip UI was introduced.

Is this intended behavior?

Are you trying to export the entire track or just the selected audio?

To export just the clip, select the clip, then do Export Selected Audio.

Otherwise you will have to have to move the trimmed clip to the start of the track.

Thanks. Selecting the clip and exporting the selection does what I want. But I’m puzzled why the beginning of the track is replaced by silence and the end is discarded, not replaced, if I do an export without selecting the clip. That seems inconsistent to me.

Also, in this article: Audio Tracks and Clips - Audacity Manual, it says, with my bolding:

You can trim a clip by dragging near the upper corner of its left and right edges.

  • Doing so will hide the waveform that goes beyond it (as opposed to fully deleting it).
  • If you make some edits to the clip and then later decide to un-trim it, you can just grab the upper corner again and extend it.
  • The hidden parts will not be played or exported.

Perhaps @LWinterberg can explain this function better than I can.

I am not able to reproduce this with WAV.


I am able to reproduce this with MP3 for all source material, which I also remember being a thing in 2012.

By default, any empty space before the start of a track will be rendered as silence when exporting the track. (This is very important when using Audacity to edit tracks that are part of a multi-track project, otherwise the clips position relative to other tracks is lost.)

To export a track without rendering preceding space as silence, there are several options:

  1. Select the audio that you want to export and use “Export Selected”.
  2. Align the clip to the start of the track (Start to zero) before exporting.
  3. Enable the option “Ignore blank space at the beginning:” in “Preferences > Import / Export”.

If you always want to ignore leading silence, the 3rd option is the best as you will only need to set it once and then Audacity will always ignore empty space at the beginning of the project.

Thanks, Steve. Option 3 is just what I need.
Sorry for the delay in letting you know.

This topic was automatically closed after 30 days. New replies are no longer allowed.