Clipfix damage stereo track sync

Audacity 2.3.1 Fedora 30

Maybe this is an handling issue, but i can reproduce the same mess again and again. The idea is to deal with loudness war damaged track from few newer CD’s in my collection. They are digitized with Asunder to 16 Bit 44.1kHz flac files before.

I’m doing what so many guides and videos do suggest.

  1. Load the track into Audacity, now the distorted waveform looking like a sausage is visible.
  2. Enable track/keep synchron
  3. Use effect/amplify and lower the track around -6dB
  4. Make a test play, the track have less volume but is in sync
  5. Use effect/clipfix on the track, here the track length seems to he reduced to half.
  6. Now the waveform looks a bit nicer, but left and right track are out of sync. Like playing the track in the mountain and getting horrible echoes :astonished:

Any idea how to avoid these de-sync?


Are you applying ClipFix to a very long track?

Yes i like to clean whole CD tracks that came with loudnesswar, so we have files up to 6 minutes.

Is there any alternative?


That shouldn’t be a problem. By “long” I was thinking of 20 minutes or more.

Is one channel visibly shorter than the other, like this:

Is there any alternative?

You could try [u]SeeDeClip[/u] but it seems to have been “upgraded” into some kind of screwy “server version” and it looks like you need the $20 USD “pro” version for clip repair.

Izotope RX has a de-clipping tool but it’s not free and I don’t know if it works with Linux/Audacity. It doesn’t officially support Audacity but it can run as a VST plug-in so it might work.

The idea is to deal with loudness war damaged track from few newer CD’s in my collection.

FYI - The “damage” isn’t JUST clipping and it’s probably not the main reason for the “bad sound”. I’ve tried Clip Fix once or twice (not an extensive experiment) and it made the waveform look better but it didn’t fix the sound of the distortion (at least not significantly) and didn’t make the recording any more “listenable”.

It’s incredible, found an 8 year old Audacity macro in my /home and i’m sure it has worked before. Today the clip fix function results to a stereo track that sound like 2 FM stations mixed up.

Normalize: ApplyGain=yes RemoveDcOffset=yes Level=-6,000000 StereoIndependent=yes
ClipFix…: thresh=95,000000
Normalize: ApplyGain=yes RemoveDcOffset=yes Level=-11,000000 StereoIndependent=yes

Bought Professional Notes for Windows, hope some day Audacity will be fixed again. Had bought seedeclip once, but it’s ability to deal with flac was and is a mess. Would be nice to stay in a linux workflow to prevent encode pooping that’s normal within windows environments.


I’d be surprised if that ever worked.
Audacity has only had “Macros” for a short while - before that it had “Chains”. As far as I’m aware, both Macros and Chains have required the decimal separator to be a dot, not a comma.

Alternative to what?
The “Loudness War” was not really a problem in the 1950’s. Yes they did have “dynamics compression” back then, but nothing like the severe compression / limiting of modern recordings.

The problem with compression, is that it’s impossible to accurately “uncompress” (expand) the dynamics unless you know the exact characteristics of the compressor used. Even if you do know the exact characteristics of the compressor, it is still very difficult to reverse the process. You can guess how much expansion to apply, and at what threshold levels, and with what frequency compensation … but it’s very likely that the results will be disappointing at best.