Clicks are driving me nuts!

I’ve been recording audiobooks for about 9 months with few problems but some time after recent windows updates, driver updates, etc., I started getting clicks in my recordings. While I can usually fix some of them fairly quickly with either tweaking a section by lowering the volume or re-recording in worst case instances, it’s a PITA and I’d really appreciate some Audacity expertise to help me out.

The clicks happen primarily around plosives but not always, sometimes in the middle of a word without a plosive in it, sometimes between words.

I’ve searched for causes but can’t seem to get a handle on anything in particular. I’m not sure if it’s due to a buffer issue, driver issue, cable, mic settings or a myriad of other possibilities.

Is there any way to look at the waveform(dB) or even a spectrogram where these clicks are located and determine what is causing the problem?

I’ve reinstalled Audacity and the Focusrite driver since the Windows updates.

Windows 10 Home Version 10.0.17763 Build 17763
Audacity 2.3.2
HP Spectre laptop, I7, 16GB SSD, all fw on laptop up to date
sE2200 microphone w/pop filter, rolloff now set to 160Hz (setting to off or 80Hz had no effect on click occurrence) - mouth one “shaka” away from pop filter
Focusrite Scarlet 2i2 USB audio interface
Focusrite ASIO settings 44.1 kHz , buffer 128
Audacity settings 44100, 32 bit float, MME, Focusrite, mono.

Any help is seriously appreciated.

mouth one “shaka” away from pop filter

I wrote that and everybody gets it wrong.

It’s one Shaka from the microphone

…and a power fist from the blast filter

Nobody will stop breathing if you get it wrong, but if you have no trouble making volume and noise, nobody cares (except I sob myself to sleep every night).

I don’t think it’s peaking and overload, either, but you can turn on View > Show Clipping to be sure. Audacity will put thin red lines in the blue waves everywhere it thinks there is serious overload damage.

Please note that if we get to two weeks or more without resolving this, the recommendation is to stop using the computer to record your voice.

Have you been through the pre-printed list?..that I can’t find right this second.

What else is running on the machine? There should be nothing else running while you record. In Windows 10 you can do a thorough shutdown with Shift-Shutdown. Wait a handful of seconds and then Start. That resets and cleans many more things than straight Restart (and takes a good deal longer).

Is the click in exactly the same place every time you play it? Drag-select about 3-5 seconds on both sides of a good, healthy click and post it in WAV format on the forum.

Scroll down from a forum text page > Attachments > Add files.

Do any of them happen over silence or very quiet passages?

I may gracefully back up and leave this to an actual Windows elf (which I’m not).

This is the clicky list for the Mac people.


Oh. One more.

Focusrite ASIO settings 44.1 kHz , buffer 128

It’s nice you did that, but plain Audacity doesn’t support ASIO services.

What happens if you just stop using the Focusrite drivers and plug the 2i2 into the computer and go. The machine should work with any normal mono or stereo sound adapter right out of the box. It’s only when you get into serious multi-channel or odd sound tricks or sound management that you start to need drivers and special software. If you’re just talking into a microphone, almost anything should work.

How many USB devices do you have hanging off the machine? Are you recording to the internal drive?

Do you have external drives or cloud drives connected? Stop doing that.


Thanks Koz.

Yep, I knew that about the shaka vs power fist but over the last couple of months since this problem began, I have been trying so many things that the variables started getting in the way.

Back to the tried and true basics of using Audacity. I’m removing the ASIO driver as soon as I’m done here. And I knew about the ASIO driver not being supported without compiling a compatible version of Audacity but must have forgotten it in the rush to fix the problem, thereby if not making the problem worse, at least doing nothing to fix it.

I’m recording to the laptop internal 512GB SSD.

Since the mic needs power, I’m running the 2i2 interface to a powered USB hub which is connected to the laptop. Also on the hub is a connection to an external monitor and an ethernet cable, so mic, external monitor and network traffic all go through the 3.0 USB port on the laptop.

A couple of the most recent click examples attached.


You should probably identify the clicks. I hear the one at “Left” (0.649) in clip 3, but I’m having trouble with the first two.


Also on the hub

There is no “also on the hub.” Never send audio through a USB hub with other stuff. USB time shares and there’s no way to set priorities.

Do a performance with nothing else connected to the hub and I bet the problems vanish.


Hi Koz.

Point taken with the USB hub. I need to use it for the mic due to 48V phantom power and it’s my only option for screen export to an external monitor, but I’ll try it with just the mic on the hub if need be.

Click 1 - click is muddled in the word “throttled”
Click 2 - click is immediately after the word “noticed”

Actually, since I deleted the Focusrite ASIO driver, I haven’t’ noticed any clicks but admittedly, I haven’t recorded much for the last several days due to company visiting from sunshine deprived states…so the jury is still out on ASIO being the only culprit.

Thanks as always for excellent advice.


The clicks are not digital in origin, but human, IMO.

Audacity’s De-Clicker plugin gets rid of them …

[ Store-bought de-clicker plugins are quicker ].

Thanks Trebor!

Something else to try if it’s still there.

With some of the clicks, I’m starting to question if the problem is at least partially with my hearing. I definitely have hearing loss is some middle to high freqs.


Wet-mouth clicks are mostly in the 4kHz-12kHz range,

If you play back at a slower speed (say 0.75x) the clicks drop into a lower frequency-range so are more audible.