Clicking sound on playback; overdub not working

Audacity 2.0.5
Ubuntu 14.04
It’s supposedly a latency issue but nothing I do with the lat correction seems to get it working
Also it won’t let me overdub no matter what I set the correction to (including 0)

The Recording Latency setting (the one you can actually change) is only obvious after you play back the tracks. It’s job is to make the new track time exactly with the old one. It has nothing to do with actually making a second track.

One of the first steps in the overdubbing tutorial is to make a plain recording. If you can’t get that far, nothing we do is going to help. So de-select Overdub in the Recording preferences and make a plain, clean recording and then play it back.

Your Audacity is six versions out of date.


As Koz said, all Latency correction does is time shift an overdubbed track after it’s been recorded.

Audacity’s “Audio to buffer” setting probably won’t help much either. If you set it to zero you won’t be able to record at all.

The answer is probably to change the pulse latency (assuming you are choosing the pulse or default recording device in Audacity’s Device Toolbar).

To change pulse latency, see

Alternatively, choose the (hw) device in Device Toolbar, so accessing the device directly and bypassing pulse. Because you are now trying to access the device directly through ALSA, if any other application is accessing the device then Audacity won’t be able to use that device. Also this denies exclusive access of a device to PulseAudio, so other applications using PulseAudio will not be able to use that device.

If you need more help, please tell us exactly what you are trying to record, and what equipment you are using to do that.

Gordian 12 is presumably using the 2.0.5 Audacity package provided by Ubuntu 14.04.

If you want the current Audacity 2.1.1 version, uninstall your 2.0.5 package then get the unofficial third-party 2.1.1 PPA from