Clicking Noise when Recording Long Audio with Soundflower

Moved to the appropriate Mac OS X board

I’ve been trying to record audio with Audacity using internal sound rather than speakers on my Mac. I’m using Soundflower in order to re-route my internal sound to Audacity.

I’m recording quite lengthy pieces at a time, and once I hit about the 20 minute mark I start getting distinct and loud clicks showing up about every half second or so.

It’s quite irritating.

Any suggestions?

Clicking and popping can mean your computer is running out of resources. How big is your hard drive and how much do you have left? Is the computer doing anything else? Do you leave Skype open in the background? Do you have a million applications “sleeping?”

Are you using USB external drives?


From the desktop: Go > Computer > Control Click on the top device (usually the system drive) > Get INFO.


What three-digit version number of Audacity? See Audacity > About Audacity… .

Are you on Mavericks or MacBook Pro? That combination can have buffering issues.

Try Audacity > Preferences… then choose “Recording” on the left. Try changing the “Audio to buffer” setting. Reducing the buffer below the default 100 ms may help (but you can’t reduce it to zero).


I’ve got about 722 gb free space to use. I did have a bunch of apps open the first time, but when I closed everything and tried again, I ran into the same problem. I’m not using external USB drives to store the audio on.

I’m using Audacity 2.0.5. I’m using the lastest mac os X, but on an iMac, not a macbook pro.

ll give the "audio to buffer setting a shot and see if that helps. Thanks guys!

on an iMac, not a macbook pro.

That may change the formulas a little. Apple shifted the battery saving on the portable machines to be much more aggressive. To give you an idea, the old animated Time Machine icon in the tool bar with the rotating arrow and the clock going backwards was replaced with a still icon with an extra arrow. It doesn’t move any more and it’s easy to miss. Apparently, that was judged to be a significant energy savings to be worth it.

There was a change between OS-X 10.9.1 and 10.9.3 where they loosened the reins a little bit. They used to try and shut down the system between words on an Audacity recording to “save energy” and that caused all sorts of problems. If you’re not up to 10.9.3 or the latest one yet, you might consider that.