Click removal removes about 5 seconds of tracks [SOLVED]

Using ver 2.1.1.
When I try to remove a definite click from the tracks, the repair effect and Click removal effect wipes out about 5 seconds of audio, using the zoom and draw tool wipes the whole tracks, so too does selecting the spike and labelling then using find zero crossing and Crtl-K.

very frustrating.

Is the problem on just one project, or can you reproduce the issue on any project?
If the problem is reproducible on any project, please give precise and detailed step by step instructions for how we may reproduce the issue.
(including, which version of Windows)

Another possible explanation - if you have Norton, turn off its temporary file cleaner. It may be deleting your temporary Audacity files.

Or save an Audacity project to your Documents folder before starting work.


Steve: The problem is the same on any project from the Audacity folder in Program Files(x86) on Win 8.1 x64.
I am zooming in to Thousandths of a second, selecting an area were the form wave shows a definite line cross either side of the click, I select Find Zero Crossings then do Ctrl-K. it removes about 5-6 seconds of sound even though only 40 milliseconds are selected.

I tried copying the project to a folder in Documents as Gale suggested, did the same operation and it worked fine, as was intended.

Gale: I don’t use Norton, It has always caused more problems than it cured. But I did try moving the project to documents. (see above)

That explains it. The “Program Files(x86)” folder should only be used for installing programs, not for saving “user data”. A normal user account does not have full read/write permissions except in their “user space”, so Audacity would not be able to write the audio data properly.
I’ll mark this topic as “solved”.

Audacity saved it there by default.

Yes it happens. Please look where you are saving to. Once you have changed the project save directory it should be remembered by Windows.