Click or pop noise being introduced at the beginning of a sample after applying Graphic EQ effect

Hey everybody, I’ve already searched a good bit on my question and haven’t found anything specific to my problem so I decided to try the forum. I’m on Windows 10 with Audacity 3.1.3, but have tried other versions too and still get the same issue.

What happens is, I have a bunch of samples opened in the same project that I’m applying different Graphic EQ values to individually. The effect works great, only, after applying it, if I drag the sample forward in time, there is a click or pop noise just as the sample begins to play. It is also present if I export the sample.

Any thoughts? Thanks!


Perhaps the EQ settings are boosting the level above 0 dB, causing clipping on playback.

Thanks for the quick reply and good suggestion. I just noticed that it sounds fine after applying the effect – but then if I move the sample forward in time, I get the click. If I move the sample forward in time before applying the effect, there is no click.

Does your project have more than one audio track?

by “sample”, do you mean “audio clip” (Audio Tracks - Audacity Manual)?

Sorry and thanks, yes – my project has multiple audio tracks, and yes, by sample I meant audio clip. Thanks again.

My guess is that the mix of tracks is going just a little over 0 dB. (When multiple tracks are played together, or mixed down, the waveforms are literally “added” together, so it’s common for the peak level of the mix to be greater than the peak level of the individual tracks.

Before exporting, it’s a good idea to mix all the tracks (“Tracks menu > Mix > Mix and Render”), and Normalize to a little below 0 dB (“-1 dB” is the default for the Normalization effect). If you want to save your project with separate tracks, “Undo” the mix before saving the project.

Okay great, thanks for all the helpful info. I do feel I should mention that this happens even when I have all other tracks muted, but I’m guessing your theory still applies…

Other things I should maybe mention: I’m only running one instance of Audacity and all other programs are closed. I’m on Windows 10. Dell laptop.

A couple of other things that can cause clicks -

If you don’t cut at a [u]Zero Crossing[/u] where the sound suddenly starts or ends in the middle of a wave you can get a click at the beginning or end of a clip.

Similarly, a [u]DC Offset[/u] will cause a click at the beginning & end.

Thank you both. I tried both of your suggestions but neither fixed the issue. I have now noticed that this click appears even after just applying the Limiter effect with default settings.

The zero crossing topic is worth careful examination.

Zoom into where the click is until you can see the individual samples. There will probably be a jump.

Theoretically you can edit the points to smooth this out but I find it quite a pain.

You can avoid this by applying the effect to a selection that starts and ends at zero crossings - and pressing Z tries to shift the ends of the current selection to matching zero crossings.

Selection by hand:
After pressing Z:
Then the changes the effect makes are less likely to introduce clicks (and pretty much guaranteed not to for deletes).

Thanks again everyone for the thoughtful and thorough replies. It seems to be the case that when apply the Graphic EQ effect, clipping is in fact being introduced by certain frequencies that I’m boosting – HOWEVER – the clipping is not being displayed in red like it normally is when applying other effects that cause clipping.

With the Limiter effect, same issue. If I apply the Limiter effect with Soft Limit selected, I get clipping during playback, but no indication in red on the waveform. (When I set it to the Hard Limit factory preset, I get no clipping.)

So it seems that clipping isn’t being displayed in red after applying the Graphic EQ or Soft Limit effects even though clipping is in fact being introduced. Should I report this as a bug, and if so, what’s the best way of going about that? Thanks again.

I can’t duplicate that… I do “see red” after boosting with EQ (I tried the Graphic EQ).