Church music director seeking help for COVID era choir

Hello all,

My wife is an organist/church music director in Philadelphia. I’m trying to use Audacity to help prepare materials for choir members to make music “together,” remotely. Like a band, only polyphonic, sacred music.

I’m on MX Linux (built on top of Debian Buster) with Audacity 2.3.2, straight from the Debian repos. What I think I want to do is:

a) generate a click track;
b) have her listen to the click track while recording the organ (or sometimes piano) part of the piece, keeping them separate (so overdubbing, right?)
c) send that as an MP3 (so mixed down to a single track, I know, but we’ll keep the .aup file for later) to each choir member;
d) have them play that on their phones while recording their own part only, also as an MP3, to send back to us;
e) put all the choir member parts together (maybe one section of SATB at a time?) with the accompaniment;
f) finally, remove the click track from the original .aup project and mix the whole thing down to one MP3 for use in the virtual church service.

Good choir, should be possible technically, if a lot of work, files flying around, etc.

BUT! I’m encountering a lot of trouble with Audacity. I’ve followed this tutorial on overdubbing:

I’ve got all the correct preferences settings…default for sound card, mono, 44,100, 32 bit, etc…whatever is called for there. Dubbing on, software playthrough off, etc. I don’t have the ability to test latency as suggested…we have to leave that to the side for the moment, and trust to fixing it “manually” later.

The key point is that I can record the click track with no problem…and then nothing else, except one single time!! If I hit R (I’ve set that to be the “record on a new track” shortcut) I get a new track, but nothing records! The meter shows my input clearly…it’s obviously being registered by the mic (built in only, at this point, but good enough; I’ve already tested it in church with organ and piano) but isn’t showing up as a waveform in Audacity. What’s going on? It worked once, after a reboot (not related to this…I had to go into Windows for something, then came back to Linux a few hours later) but not again since. Records one single track…either my voice, or a click track…but then hitting R to record the next track fails as described.

I know this can’t be a big deal…some small, stupid detail, all my doing, no doubt…but what is it?

Many thanks, sorry for the long post but more detail is better, no? happy to provide even more if called for!

Nobody has to use Overdubbing. You send out the reference or backing track and everybody plays it on their smartphone into headphones and then just performs into a fresh recording in Audacity or any other recorder.

That’s what this woman is doing.

The giveaway is she’s only wearing one muff. The other ear is free so she can hear what she’s doing. Another performer in this song is using full-on overdubbing and can hear himself in addition to the backing track in his headphones.

Screen Shot 2020-05-17 at 19.17.22.png
The reference track is important. It needs enough lead-in so everyone has time to sway to the beat and tap their foot before they have to sing the first note. You cut all that out later.

This is the finished song. The producer is Josh, lower left.

So the organ/piano is recorded clean and simple with the performer listening to the click track on her headphones plugged into her smartphone. No overdubbing. Make sure to do a good lead-in.

It’s extraordinarily important that the organ/piano part is played exactly to the rhythm. That music is the reference that all the other performers are going to play to with the organ [piano] in their headphones plugged into their smartphone. Again, if one of the performers has it together to set up overdubbing, go for it. But you don’t have to.

There are techniques where each performer counts down out loud to the lead-in in their ears before they start performing. That will give you a head start in syncing everything up.

Please note there are going to be people who start in sync and don’t end up that way. That’s a job for Effect > Change Speed until both ends line up. Make a note of what you did. That performer will probably always be that far off.

There may also be people where both ends line up but not the middle. Those are the computers that need servicing or adjustment. There is no rescuing those.

more detail is better, no?

Not once in there did you tell us what the microphone was or how you had it connected.

There is a caution about MP3. MP3 gets its convenient, small files by cleverly damaging the sound in ways that are hard to hear. If you try to make an MP3 from an MP3, the damage will be less hidden. By the time you get to the third MP3, everybody can hear the damage.

If you’re shipping mono voice tracks around, use Constant Bitrate, 192 quality or higher. The files will be larger, but production will be much nicer.

If your microphone fails to show up in Audacity, Restart Audacity or Transport > Rescan. If you connect the microphone last, Audacity won’t easily find it.


There is one more odd reason for music to fail. If you have chat, conference, or group voice services on your machine, it may not pass music. Echo cancellation and auto noise reduction hates music. Make sure all those corrections are turned off before you try to record music. That goes for everybody else, too.


When you do get it to work, we will, of course, need the address where to listen to it.


This is too good. The first part is the finished song. The second part is the outtakes.

“Wait. I thought you were going to… Let me restart the camera.”


Thanks for all your input, though in fact I know about the other ways you suggest to do this, listening to one half of headphones and using the other ear for myself, the importance of “absolute” fidelity to the rhythm, the degradation introduced by MP3, etc… my wife has been a church organist for over 40 years…just never in pandemic times, so we’ve little or no familiarity with the technical side of this problem.

All of your suggestions notwithstanding, my question remains, why isn’t Audacity working as the tutorial says it does? I don’t want to dispense with the click track to accompany the organ (or piano) accompaniment, I want them both on the reference tape for the choir members’ ease of use. What I meant with “don’t I have to use overdubbing” was simply, "is there anyway to get the click-track and the accompaniment on two separate tracks without overdubbing…? Or do I have to do it. If the answer is, “yes, you must overdub to get those two tracks out to the choristers,” then I’m no further along now than yesterday…what is happening in my particular Linux environment that keeps Audacity from doing as described in the tutorial?

…and later…

In fact I do say that I’m using the internal mic, in the absence of anything better, and I also say it is picked up just fine…that’s not the issue:

The meter shows my input clearly…it’s obviously being registered by the mic (built in only, at this point, but good enough; I’ve already tested it in church with organ and piano)

So, I’m back to my original question…why isn’t this working. I just tried again, exact same problem. Rebooted, started Audacity before any other program, nothing else running on a brand new, Lenovo T495, 24 gig of RAM, 1TB SSD, all software updated. Here are some further things that could perhaps help locate the problem:

  • Sound card is "Generic: HDA-Intel - HD-Audio Generic

  • Preferences:Devices:Interface:Host:ALSA:Port-Audio V19.6.0-devel
    Preferences:Devices:Recording:Channels:1 (Mono)
    Preferences:Devices:Latency:Buffer Length: 100 milliseconds
    Preferences:Devices:Latency:Latency compensation -130 milliseconds

  • Preferences:Playback: all defaults, nothing changed

  • Preferences:Recording:Options: play other tracks while recording (overdub) is checked
    Preferences:Recording:Options: software playthrough of input is unchecked
    Preferences:Recording:Options: record on a new track is checked
    Preferences:Recording:Options: detect dropouts is unchecked

  • Preferences:Quality:Sampling:Default Sample Rate: 44100 Hz
    Preferences:Quality:Sampling:Default Sample Format: 32-bit float

  • Snap-to: Off

If I record myself singing, there’s no trouble. If I record a rhythm track, there’s no problem. If I append my singing onto the rhythm track (i.e., I uncheck “record on a new track,” there’s no problem. But if I record a click track or my voice, hit “home,” and then hit the Record button…I get one “tick” sound, and then nothing.

What else can I tell you, that would help diagnose and resolve this problem? And thanks so much for your kind attention. The church choir may not be able to sing in person, all together, for many, many months to come…so getting this to work is a high priority, and just shouldn’t be that hard…right?

I’ve read through your original post, and it looks like the problem is just setting up your sound system to do what you want.

Before I go charging off in the wrong direction, I’d like to check a few things with you:

Do actually mean that you are “recording” the click track, or are you “generating” the click track with Rhythm Track - Audacity Manual ?

If you are “recording” it, how are you doing that?

I missed that too, so thanks for repeating.

That’s peculiar.
Does the cursor move to the right as if recording, or is it stuck at time=0?